summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Desaulniers2018-11-18 12:00:14 -0500
committerPatrick Desaulniers2018-11-18 12:00:14 -0500
commitb22fe9a54d77dddfbb7c29dc85087319da377fe1 (patch)
tree12f0695cac545e6dca95ee4a339b74d8ba82323c /PKGBUILD
downloadaur-b22fe9a54d77dddfbb7c29dc85087319da377fe1.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3cf9cafef563
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Patrick Desaulniers <desaulniers dot patrick at carrefour dot cegepvicto dot ca>
+
+pkgname=bitrot-git
+pkgver=r8.66828d4
+pkgrel=1
+pkgdesc="Bitrot audio plugins (LV2, VST2 and LADSPA)"
+arch=('i686' 'x86_64')
+url="https://github.com/grejppi/bitrot.git"
+license=('GPL')
+depends=('gcc-libs')
+makedepends=('git' 'python')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+source=("${pkgname%-*}::git://github.com/grejppi/bitrot")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-*}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${pkgname%-*}"
+ git submodule update --init --recursive
+ ./waf configure --prefix="/usr"
+}
+
+build() {
+ cd "${pkgname%-*}"
+ ./waf
+}
+
+package() {
+ cd "${pkgname%-*}"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ ./waf install --destdir="$pkgdir"
+}