summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlibertylocked2018-10-15 21:26:15 -0400
committerlibertylocked2018-10-15 21:26:15 -0400
commitcf31f5efa4d51688fe943336959cf2194e1c139a (patch)
tree46f8619ed1f47c50272619dd64149403adc9d37d /PKGBUILD
parentf4a7e433fdcd3d2d8ce376469bbdd34741e0697b (diff)
downloadaur-cf31f5efa4d51688fe943336959cf2194e1c139a.tar.gz
Use source tarball instead of git clone
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 39e81a7010fd..0e8574552d91 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: libertylocked <libertylocked@disroot.org>
# Contributor: Stephen Brown II <Stephen [dot] Brown2 [at] gmail.com>
pkgname=bitwarden-cli
-_pkgname=bitwarden-cli
pkgver=1.3.0
-pkgrel=2
+# commit of bitwarden/jslib
+_jslibcommit='1f9fbe43d7a78349e6fe994fa70d9b773af5c0f9'
+pkgrel=3
pkgdesc="The command line vault (Windows, macOS, & Linux). bitwarden.com"
arch=('x86_64')
url="https://bitwarden.com"
@@ -12,29 +13,28 @@ makedepends=('nodejs' 'npm')
depends=('nodejs')
conflicts=('bitwarden-cli-git')
options=('!strip')
-source=("${_pkgname}-git-repo::git+https://github.com/bitwarden/cli.git#tag=v${pkgver}"
- 'jslib-git-repo::git+https://github.com/bitwarden/jslib.git'
+source=("bitwarden-cli-source.tar.gz::https://github.com/bitwarden/cli/archive/v${pkgver}.tar.gz"
+ "jslib-source.tar.gz::https://github.com/bitwarden/jslib/archive/${_jslibcommit}.tar.gz"
'bw.sh')
-sha512sums=('SKIP'
- 'SKIP'
+sha512sums=('64767df288256d9d5727d483d6ac546ea4a7443033588eb9b38a5c1a10731545354028a955138984af23c5b377eb8ab751e273b456edb5c0906701a0360e8524'
+ '4a31086ec86119ac74415dc0cabdbc2f332e0bf614d24d398fa622e7aa1f9cb3f679afc473b6bc8f783d95ae6ce070137f94320aa82cc7b9caccdb26e82e024d'
'71729c0ee95429ab03fa586de6bbf8ebad29d6d5544775564bb35eaa68cc4a915007db54b5928e99234bfe7828491829a5d32750f641056a0b68e05aa842f9ee')
prepare() {
- cd "${_pkgname}-git-repo"
- git submodule init
- git config submodule.jslib.url $srcdir/jslib-git-repo
- git submodule update
+ # make a symlink of jslib in cli since the submodule is missing in sourceball
+ rmdir "${srcdir}/cli-${pkgver}/jslib"
+ ln -s "${srcdir}/jslib-${_jslibcommit}" "${srcdir}/cli-${pkgver}/jslib"
}
build() {
- cd "${_pkgname}-git-repo"
+ cd "${srcdir}/cli-${pkgver}"
npm install
npm run build:prod
}
package() {
- cd "${_pkgname}-git-repo"
-
+ cd "${srcdir}/cli-${pkgver}"
+
install -dm755 "${pkgdir}/usr/lib/${_pkgname}"
cp -a build/. "${pkgdir}/usr/lib/${_pkgname}/"