summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarkus Richter2018-09-20 19:33:29 +0200
committerMarkus Richter2018-09-20 21:50:25 +0200
commit5c30385e801745963fe0df7d43b27cbbd13b1c59 (patch)
tree41e1e4b7e54542b8003ab89017b3ed29a60186dc /PKGBUILD
parentcff78125c4ac67c93da3f94cb2ffbbd0568c0c97 (diff)
downloadaur-5c30385e801745963fe0df7d43b27cbbd13b1c59.tar.gz
fixed openssl v1.1.1 incompatibility, clarified email configuration
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 898003d2ffb3..155ed407733e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=bitwarden_rs
_pkgbase=bitwarden_rs
pkgver=1.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="An unofficial lightweight implementation of the bitwarden-server using rust and sqlite. Does NOT include the web-interface."
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="https://github.com/dani-garcia/bitwarden_rs"
@@ -17,17 +17,20 @@ install=bitwarden_rs.install
source=("https://github.com/dani-garcia/bitwarden_rs/archive/$pkgver.tar.gz"
"${_pkgbase}.install"
"${_pkgbase}.service"
- "0001-Disable-Vault.patch")
+ "0001-Disable-Vault.patch"
+ "0002-Fix-OpenSSL.patch")
sha512sums=('3b8290b5f5055b48ffd732b823ca9da6d2f78c0511daab8d05490f10d087d001b417654711ff0f7dce97f3885b0fe4cf72567878532e7b004a8c37337b97d7f8'
'399e63002acb764895bbcf3b983642c8858343b36909eeeb73133de1a9740a3d81232bc206ff6bf3daed50f72354c5e6fd5314d0d044acd9f1cb23a933b1dd74'
'773dc0830b4eaf3a1d4134a52a6157e6a94265c6212ae8cc24b9584f9c444b9a0f822325f487ce9c23c363f743f1f64f269352f030e98e336816aee0a68048f6'
- '704057f0bf6d71ab9888378c3d66ee97c5019e8b18d0f22f93615fef60bef7df80a11ad7ebf5cca1cc49c90ba3f9d84515a160555e395790f325510f8a81f5cd')
+ 'cbc151fc41ebffa611e144575bea463ab31a75d55ec1a331795eded3d415db8a221d24c75efe0c97c56fc33b80ffca53683af3d240af547b0d4a222d3095e960'
+ 'd66facb9dbe5863443d2b2383646b41fe528cb0ab967c156876852d9c6b8faac05251bdcdf584cff5d7d4d9e8ee162fe32bbfb0873d0fdb7393cf74962cd8c4f')
_src="$pkgname-$pkgver"
build() {
#build bitwarden_rs
cd "$srcdir/$_src"
patch -N -i "$srcdir/0001-Disable-Vault.patch"
+ patch -N -p1 -i "$srcdir/0002-Fix-OpenSSL.patch"
cargo build --release
}