summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarkus Richter2019-12-01 00:05:35 +0100
committerMarkus Richter2019-12-01 00:05:35 +0100
commit17dfecebc3a391e50b5d8d63826f3b7678f78391 (patch)
tree0284938ae080eb90711661949d328f6917eb278e /PKGBUILD
parentbdfeac2c17207238c80dcde123d81a82fc03eeb4 (diff)
downloadaur-17dfecebc3a391e50b5d8d63826f3b7678f78391.tar.gz
1.13.0
Upstream Changelog: - Implemented email verification, to disable users until the email is verified you can use `SIGNUPS_VERIFY=true`, default is false. There are also options to change the options for verification mail resending, check the `.env.template` file. - Also implemented welcome email, change email confirmation and account deletion confirmation. - Modified icon parsing to accept favicons using DataURLs - Updated dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b694094dd96b..77a602950cad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bitwarden_rs
_pkgbase=bitwarden_rs
-pkgver=1.12.0
+pkgver=1.13.0
pkgrel=1
pkgdesc="An unofficial lightweight implementation of the bitwarden-server using rust and sqlite. Does NOT include the web-interface."
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
@@ -17,11 +17,13 @@ install=bitwarden_rs.install
source=("https://github.com/dani-garcia/bitwarden_rs/archive/$pkgver.tar.gz"
"${_pkgbase}.install"
"${_pkgbase}.service"
- "0001-Disable-Vault.patch")
-sha512sums=('5cdb328532a85ede7ca306192ba0fa311bdcc6679aa4b29b6928bd183d07c5b1fbf21de053d14cb87a6ecf8a338166c6926274a98a6ab00245422e4f6f351db4'
+ "0001-Disable-Vault.patch"
+ "0002-Fix-tests.patch")
+sha512sums=('ef17482b98b8caa089c957bc3db53f3adcbcdd1b8b64cb4b94612875bf939e259b9ef5928d2aaf99490534a83b48a3ec06933c28b243be1c41bf3dfbe68f5c8d'
'399e63002acb764895bbcf3b983642c8858343b36909eeeb73133de1a9740a3d81232bc206ff6bf3daed50f72354c5e6fd5314d0d044acd9f1cb23a933b1dd74'
'4ce188956f6fe7cfdb711b1505f6344ed2775751ea112a0506dc96455c2705ab8529ec442e4747d7810fc3535b4ca78d1864e874dab5b5306373587097e02658'
- 'a6f2361c7aa83e63b9a557500406b0cd660e0d7f8b16345f859faa3f96e22bdcecd7589711960486fa0401896291f7d46f66882744c69117fc146056f4a49028')
+ 'a6f2361c7aa83e63b9a557500406b0cd660e0d7f8b16345f859faa3f96e22bdcecd7589711960486fa0401896291f7d46f66882744c69117fc146056f4a49028'
+ '5d0e5a96dbd23d2e2fb1a89e2db8817018feb6a05dc854c5a9a3d1b84f94605c6a1f597dc233ec5ca6ff7adb18bbfdca2bcb2645de31c17f38470f649468ef44')
_src="$pkgname-$pkgver"
@@ -30,6 +32,7 @@ build() {
#build bitwarden_rs
cd "$srcdir/$_src"
patch -N -p1 -i "$srcdir/0001-Disable-Vault.patch"
+ patch -N -p1 -i "$srcdir/0002-Fix-tests.patch"
cargo build --release --locked --features sqlite
}