summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarkus Richter2019-01-13 18:22:40 +0100
committerMarkus Richter2019-01-13 18:22:40 +0100
commit2cb46bdefa57f0a4cbb5cb46dc85f161c3cc01ad (patch)
tree7cbb0597c43fecb0d3669af538aac52ae6c0cf2b /PKGBUILD
parent3ccc4ffeeb9bd9b3db55bb854a3310de8aa2ce3b (diff)
downloadaur-2cb46bdefa57f0a4cbb5cb46dc85f161c3cc01ad.tar.gz
1.6.1
temporarily fix SSL Error (https://github.com/dani-garcia/bitwarden_rs/issues/337), revert aarch64 workaround Upstream Changelog: - Enabled Yubikey support on AArch64 - Fixed error when editing cipher with attachment - Fixed error incorrectly hiding cipher when deleting attachment - Added unofficial server warning
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 8 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b1702bf619a2..20f61729bf70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=bitwarden_rs
_pkgbase=bitwarden_rs
-pkgver=1.6.0
-pkgrel=2
+pkgver=1.6.1
+pkgrel=1
pkgdesc="An unofficial lightweight implementation of the bitwarden-server using rust and sqlite. Does NOT include the web-interface."
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="https://github.com/dani-garcia/bitwarden_rs"
@@ -17,28 +17,23 @@ install=bitwarden_rs.install
source=("https://github.com/dani-garcia/bitwarden_rs/archive/$pkgver.tar.gz"
"${_pkgbase}.install"
"${_pkgbase}.service"
- "0001-Disable-Vault.patch")
-sha512sums=('08f8987b6cc7f42d9bec08b67edaebfa872582c79e0959a03aa1a7b50fcffe29824f9d9015d956344e0ab75081e996ea0c375def8f12a430b6dc22b5bea8bf51'
+ "0001-Disable-Vault.patch"
+ "0002-Update-Yubico-Dep.patch")
+sha512sums=('4ff36f0104368e9544a04b1f0d11e4c1a16d726dcbaeb432f83251ed413971b27b71acddb5484bc0670d3f281c74fa0624b0f2f1ef5e44e4950508fd4a7e35b4'
'399e63002acb764895bbcf3b983642c8858343b36909eeeb73133de1a9740a3d81232bc206ff6bf3daed50f72354c5e6fd5314d0d044acd9f1cb23a933b1dd74'
'4ce188956f6fe7cfdb711b1505f6344ed2775751ea112a0506dc96455c2705ab8529ec442e4747d7810fc3535b4ca78d1864e874dab5b5306373587097e02658'
- 'a6f2361c7aa83e63b9a557500406b0cd660e0d7f8b16345f859faa3f96e22bdcecd7589711960486fa0401896291f7d46f66882744c69117fc146056f4a49028')
+ 'a6f2361c7aa83e63b9a557500406b0cd660e0d7f8b16345f859faa3f96e22bdcecd7589711960486fa0401896291f7d46f66882744c69117fc146056f4a49028'
+ 'ccb82c2d895290acc2367797ecca6c050f0ce353932efeda15e4f96ed227a7e60cf1325731072b1e661a4e6f5bc705ae95c1badb1403911db1e5b6e94bb0a4cd')
_src="$pkgname-$pkgver"
build() {
#build bitwarden_rs
cd "$srcdir/$_src"
patch -N -p1 -i "$srcdir/0001-Disable-Vault.patch"
+ patch -N -p1 -i "$srcdir/0002-Update-Yubico-Dep.patch"
cargo build --release
}
-# for aarch64, disable yubikey support (https://github.com/dani-garcia/bitwarden_rs/issues/262)
-build_aarch64() {
- #build bitwarden_rs
- cd "$srcdir/$_src"
- patch -N -p1 -i "$srcdir/0001-Disable-Vault.patch"
- cargo build --release --no-default-features
-}
-
package() {
# setup systemd service
install -D -m 0644 "$srcdir/bitwarden_rs.service" "$pkgdir/usr/lib/systemd/system/bitwarden_rs.service"