summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarkus Richter2019-01-11 13:43:07 +0100
committerMarkus Richter2019-01-11 13:43:45 +0100
commit3ccc4ffeeb9bd9b3db55bb854a3310de8aa2ce3b (patch)
tree30e2274c5d684d5b5de8075a658f73e161a071ea /PKGBUILD
parent58ccc0a166d9bf9a0e5e1e30f49541999f3a5d53 (diff)
downloadaur-3ccc4ffeeb9bd9b3db55bb854a3310de8aa2ce3b.tar.gz
Added aarch64 workaround (https://github.com/dani-garcia/bitwarden_rs/issues/262)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ce36b70d629..b1702bf619a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=bitwarden_rs
_pkgbase=bitwarden_rs
pkgver=1.6.0
-pkgrel=1
+pkgrel=2
pkgdesc="An unofficial lightweight implementation of the bitwarden-server using rust and sqlite. Does NOT include the web-interface."
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="https://github.com/dani-garcia/bitwarden_rs"
@@ -31,6 +31,14 @@ build() {
cargo build --release
}
+# for aarch64, disable yubikey support (https://github.com/dani-garcia/bitwarden_rs/issues/262)
+build_aarch64() {
+ #build bitwarden_rs
+ cd "$srcdir/$_src"
+ patch -N -p1 -i "$srcdir/0001-Disable-Vault.patch"
+ cargo build --release --no-default-features
+}
+
package() {
# setup systemd service
install -D -m 0644 "$srcdir/bitwarden_rs.service" "$pkgdir/usr/lib/systemd/system/bitwarden_rs.service"