summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarkus Richter2019-08-28 19:14:05 +0200
committerMarkus Richter2019-08-28 19:20:41 +0200
commit40861a5d95d87700935f848deebdbe2e41a657e8 (patch)
tree25cf614a7651075bd3bf4bf222901e2211e5b230 /PKGBUILD
parent4ba9bb6981d6b5897feea6c1ef9b43b454969fc9 (diff)
downloadaur-40861a5d95d87700935f848deebdbe2e41a657e8.tar.gz
1.10.0
Upstream Changelog: - Added MySQL support - Added backup option in the admin panel for the SQLite backend, remember to transfer those copies to separate drives! - Updated HaveIBeenPwned API to V3, which requires a paid API key: https://www.troyhunt.com/authentication-and-the-have-i-been-pwned-api/ - Added option in admin panel to remove users two factor authentication, in case of loss or bug - Allowed explicitly defining the SMTP authentication mechanism - Added notification email when a user logs in on a new device - Updated web vault to 2.11.0 - Added proxy support for the icon fetching service - Other bug fixes
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index adacce153d5f..ad1bbdfdff34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bitwarden_rs
_pkgbase=bitwarden_rs
-pkgver=1.9.1
+pkgver=1.10.0
pkgrel=1
pkgdesc="An unofficial lightweight implementation of the bitwarden-server using rust and sqlite. Does NOT include the web-interface."
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
@@ -18,7 +18,7 @@ source=("https://github.com/dani-garcia/bitwarden_rs/archive/$pkgver.tar.gz"
"${_pkgbase}.install"
"${_pkgbase}.service"
"0001-Disable-Vault.patch")
-sha512sums=('7c18e8e1c619261e040de5c0e9d6a89583fac2ecf564699b81dcf2a8fad12d15b331bf0d9cf90bde931cd15bc29d8cbe3f3ed907256284400fff27c28393b59e'
+sha512sums=('3744f3d01affa7b818c12991c74d7c073849a193838376a4d7f49fa1926d2d6d1309b2371bd4390b8631cc763806a8d03375ca057bf2945c6348d547eedbe2be'
'399e63002acb764895bbcf3b983642c8858343b36909eeeb73133de1a9740a3d81232bc206ff6bf3daed50f72354c5e6fd5314d0d044acd9f1cb23a933b1dd74'
'4ce188956f6fe7cfdb711b1505f6344ed2775751ea112a0506dc96455c2705ab8529ec442e4747d7810fc3535b4ca78d1864e874dab5b5306373587097e02658'
'a6f2361c7aa83e63b9a557500406b0cd660e0d7f8b16345f859faa3f96e22bdcecd7589711960486fa0401896291f7d46f66882744c69117fc146056f4a49028')
@@ -28,7 +28,7 @@ build() {
#build bitwarden_rs
cd "$srcdir/$_src"
patch -N -p1 -i "$srcdir/0001-Disable-Vault.patch"
- cargo build --release
+ cargo build --release --features sqlite
}
package() {