summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarkus Richter2019-10-10 13:57:05 +0200
committerMarkus Richter2019-10-10 14:17:23 +0200
commit79624d27707d808c8dfdd85ef246a67bdc954f29 (patch)
tree3a9f9dcbed4240fe045ff5ff48c778a1f342a06e /PKGBUILD
parent6b9c4240ce809c0585ae068b6ca44bc13f0ef376 (diff)
downloadaur-79624d27707d808c8dfdd85ef246a67bdc954f29.tar.gz
1.11.0
Upstream Changelog: - Added initial PostgresSQL support (enabled in the AUR package bitwarden_rs-postgresql) - Added new icon blacklisting option, to block all non global IPs (ICON_BLACKLIST_NON_GLOBAL_IPS) - Admin page scripts are loaded locally instead of using a CDN - Added CORS support - Added email 2FA - other Docker image related changes (omitted)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 049be938bce6..9d4b8542e08e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=bitwarden_rs
_pkgbase=bitwarden_rs
-pkgver=1.10.0
-pkgrel=3
+pkgver=1.11.0
+pkgrel=1
pkgdesc="An unofficial lightweight implementation of the bitwarden-server using rust and sqlite. Does NOT include the web-interface."
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="https://github.com/dani-garcia/bitwarden_rs"
@@ -11,7 +11,7 @@ license=('GPL3')
depends=('openssl')
makedepends=('rust-nightly' 'cargo-nightly')
optdepends=("bitwarden_rs-vault: Web Interface 'Vault'")
-conflicts=("${_pkgbase}-git" "${_pkgbase}-mysql")
+conflicts=("${_pkgbase}-git" "${_pkgbase}-mysql" "${_pkgbase}-postgresql")
backup=('etc/bitwarden_rs.env')
install=bitwarden_rs.install
source=("https://github.com/dani-garcia/bitwarden_rs/archive/$pkgver.tar.gz"
@@ -19,11 +19,11 @@ source=("https://github.com/dani-garcia/bitwarden_rs/archive/$pkgver.tar.gz"
"${_pkgbase}.service"
"0001-Disable-Vault.patch")
source_armv7h=("0002-Rollback-ARM-Toolchain.patch")
-sha512sums=('3744f3d01affa7b818c12991c74d7c073849a193838376a4d7f49fa1926d2d6d1309b2371bd4390b8631cc763806a8d03375ca057bf2945c6348d547eedbe2be'
+sha512sums=('d45e3a88e5569689e9c94645f97716c05945c23aa76f1dd16e06d929d293ed90622414492f196d8ee6220477f499d3be9048ebf6ccaaca5e86370f65df0c6c2c'
'399e63002acb764895bbcf3b983642c8858343b36909eeeb73133de1a9740a3d81232bc206ff6bf3daed50f72354c5e6fd5314d0d044acd9f1cb23a933b1dd74'
'4ce188956f6fe7cfdb711b1505f6344ed2775751ea112a0506dc96455c2705ab8529ec442e4747d7810fc3535b4ca78d1864e874dab5b5306373587097e02658'
'a6f2361c7aa83e63b9a557500406b0cd660e0d7f8b16345f859faa3f96e22bdcecd7589711960486fa0401896291f7d46f66882744c69117fc146056f4a49028')
-sha512sums_armv7h=('3246620e87cfd37b54b9916eea7fe5ac9a0c8d1066dbd84fe7e5a3ea4daf4a1295fc8dcc3dea7841ac0d1dec839f7119f0fc963c3782361dbdefa9b86193f5f1')
+sha512sums_armv7h=('f26044402b04cc8494cf97b8592ad792bdda875f13598028f020757f8b79bce03059fabf11c80f78bec392f45ab713e861711026881b152df4fb2dcf675e8247')
_src="$pkgname-$pkgver"
build() {