summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarkus Richter2019-02-09 15:59:17 +0100
committerMarkus Richter2019-02-09 15:59:17 +0100
commitb061bf7a703e1c4ec22ba4e9d61421a2524effc3 (patch)
treee5b4d98be9f0e3d0d32dcd15b50587576ae56f7d /PKGBUILD
parent2cb46bdefa57f0a4cbb5cb46dc85f161c3cc01ad (diff)
downloadaur-b061bf7a703e1c4ec22ba4e9d61421a2524effc3.tar.gz
1.7.0
Upstream Changelog: - Added configuration menu, accessible from the admin panel. This saves the user settings to a JSON file, by default in data/config.json, but configurable with the CONFIG_FILE environment variable. - Added templating support for emails, can be added to $DATA_FOLDER/templates/email, or $TEMPLATES_FOLDER/email, if configured. Check here for examples. - Added reload templates option, useful during development. Set RELOAD_TEMPLATES to true to enable. - The templates use the Handlebars format. - Improved icon downloader, now we don't use the upstream server anymore. - Added option to disable icon download, set DISABLE_ICON_DOWNLOAD to true. - Note that icons already in the cache will still be served. With this, if ICON_CACHE_TTL is set to 0, the cached icons will not expire. - Admin panel improvements: - Organization, 2FA status and disabled user badges - Deauthorize user sessions button - Now using templates - Added Feature-Policy header. - Created recovery code when registering a YubiKey - Now the .env file is only read from the current directory. - Other fixes and dependency updates
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 20f61729bf70..83d7a6e41473 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bitwarden_rs
_pkgbase=bitwarden_rs
-pkgver=1.6.1
+pkgver=1.7.0
pkgrel=1
pkgdesc="An unofficial lightweight implementation of the bitwarden-server using rust and sqlite. Does NOT include the web-interface."
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
@@ -17,20 +17,17 @@ install=bitwarden_rs.install
source=("https://github.com/dani-garcia/bitwarden_rs/archive/$pkgver.tar.gz"
"${_pkgbase}.install"
"${_pkgbase}.service"
- "0001-Disable-Vault.patch"
- "0002-Update-Yubico-Dep.patch")
-sha512sums=('4ff36f0104368e9544a04b1f0d11e4c1a16d726dcbaeb432f83251ed413971b27b71acddb5484bc0670d3f281c74fa0624b0f2f1ef5e44e4950508fd4a7e35b4'
+ "0001-Disable-Vault.patch")
+sha512sums=('434a1aaa721f82eaa9eb391ed48df210a14b15bb0c1ef975a5f6dc1b2a50721369b586fcc3e8447f4a82ef98c6eeb26d46a414959545f90c4683312ab001396e'
'399e63002acb764895bbcf3b983642c8858343b36909eeeb73133de1a9740a3d81232bc206ff6bf3daed50f72354c5e6fd5314d0d044acd9f1cb23a933b1dd74'
'4ce188956f6fe7cfdb711b1505f6344ed2775751ea112a0506dc96455c2705ab8529ec442e4747d7810fc3535b4ca78d1864e874dab5b5306373587097e02658'
- 'a6f2361c7aa83e63b9a557500406b0cd660e0d7f8b16345f859faa3f96e22bdcecd7589711960486fa0401896291f7d46f66882744c69117fc146056f4a49028'
- 'ccb82c2d895290acc2367797ecca6c050f0ce353932efeda15e4f96ed227a7e60cf1325731072b1e661a4e6f5bc705ae95c1badb1403911db1e5b6e94bb0a4cd')
+ 'a6f2361c7aa83e63b9a557500406b0cd660e0d7f8b16345f859faa3f96e22bdcecd7589711960486fa0401896291f7d46f66882744c69117fc146056f4a49028')
_src="$pkgname-$pkgver"
build() {
#build bitwarden_rs
cd "$srcdir/$_src"
patch -N -p1 -i "$srcdir/0001-Disable-Vault.patch"
- patch -N -p1 -i "$srcdir/0002-Update-Yubico-Dep.patch"
cargo build --release
}