summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarkus Richter2020-03-13 21:34:08 +0100
committerMarkus Richter2020-03-13 21:34:08 +0100
commitd6c3aee95d7fe871f7682fc39b3a70c01e476e7e (patch)
tree48299086fd2788c956388b2222cb72316044d02b /PKGBUILD
parentc729d85279c01843d23457463b1309f6a732524f (diff)
downloadaur-d6c3aee95d7fe871f7682fc39b3a70c01e476e7e.tar.gz
1.14
- Add notice to the top of bitwarden_rs.env and update patchfile - Make package section of PKGBUILD more consistent Upstream Changelog: - Added support for running on subpath, simply add the subpath to the DOMAIN variable: DOMAIN=https://example.com/custom-path - Attachment size limits, per-user and per-organization, set USER_ATTACHMENT_LIMIT or ORG_ATTACHMENT_LIMIT to a value in kilobytes to apply it. - Updated U2F library which might solve some U2F certificate errors. - Added SMTP test button in the admin page. - Now accepting y/n, True/False, 1/0 as config options that are booleans. - Fixed error Unique constraint violation when using Two Factor and Postgres. - Fixed error with can_signup_user that didn't allow to change the email address. - Don't error if admin token is empty but disabled - Now email domains are converted to punycode before sending - Enable icons to be cached in the clients - Added option to change invitation org name - Enabled the sending of invitations from the admin panel, even when disabled - Dependency updates
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b907725758ab..091c4550142b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=bitwarden_rs
_pkgbase=bitwarden_rs
-pkgver=1.13.1
+pkgver=1.14
pkgrel=1
pkgdesc="An unofficial lightweight implementation of the bitwarden-server using rust and sqlite. Does NOT include the web-interface."
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
@@ -21,12 +21,12 @@ source=("https://github.com/dani-garcia/bitwarden_rs/archive/$pkgver.tar.gz"
"${_pkgbase}.sysusers.conf"
"${_pkgbase}.tmpfiles.conf"
"0001-Disable-Vault.patch")
-sha512sums=('f032749606745ab1fd78cc0429fff3e9711522a94098f57d0134fa0f8dbfc07814d5b2a71e53028f8f911fd9c233fdedb8f68822096229a00cef189b41b6e717'
+sha512sums=('f9aa250f1dacc4a8d5b582ced57b11db3bd9f0880309fe7ea33065eb5d4f42baf1d0d704a810741bb8a7ad34e66b400f034e655076cdadb00f82c1c89630061a'
'ae1e05b613d3178bf3fa273ff6661c567140a43826e681b5164ef7d101c1243e5ff93e9caf7193984626d363b8b8b7c076e6646b865699d4cbe482a3dc4f91e7'
'60a406c8fea4bb651974b3fd386f66a0fcf73bfcc29bffe171b92134e2e81b6374ac6be879eb420208ecd77911b7d157db587510347e56ecb72aec34ac90fbe6'
'15b00b0dc9122f98ce8d7b55668fdfbb2e0387563e7d9ad6c0ebc73b75e46e1ccdb3a2186a453795a1b3e2d45358ff5a8076d5cf30319ab2c21539d20cff81c6'
'6fd0ea962f077f92ad7f55a1bab479e68e3463b41eb171d501847554b676b7ecf05e016544f6331bdb53bf71038fcf2ce67ad213d0a7c2f93acbafd72e8441a6'
- 'a6f2361c7aa83e63b9a557500406b0cd660e0d7f8b16345f859faa3f96e22bdcecd7589711960486fa0401896291f7d46f66882744c69117fc146056f4a49028')
+ '9fde678747d120704d0d99751af1eebd89ba2643af5917da9d9d2a8712fe5bb6ef1d3545d3b669467d14cab51c0c1514853364f323ff92bab7e7ed8501fe5b56')
_src="$pkgname-$pkgver"
@@ -55,5 +55,5 @@ package() {
install -D -m 0644 "$srcdir/$_src/.env.template" "$pkgdir/etc/bitwarden_rs.env"
# copy binary
- install -D -m0755 "$srcdir/$_src/target/release/bitwarden_rs" "$pkgdir/usr/bin/bitwarden_rs"
+ install -D -m 0755 "$srcdir/$_src/target/release/bitwarden_rs" "$pkgdir/usr/bin/bitwarden_rs"
}