summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames Groom2020-08-31 03:53:24 +1000
committerJames Groom2020-08-31 03:53:24 +1000
commit5ef1f5c13792d8291b8a1bba6c932e8fb3aa42ac (patch)
tree5c7c7f4aee29099c559c0921fbd61303a2b96022 /PKGBUILD
downloadaur-5ef1f5c13792d8291b8a1bba6c932e8fb3aa42ac.tar.gz
Init for BizHawk 2.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d90611d1fa12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: James Groom <OSSYoshiRulz at gmail dot com>
+pkgname=bizhawk-monort
+_providesName=bizhawk
+pkgver=2.5
+_archiveName="BizHawk-2.5.0"
+pkgrel=1
+pkgdesc="A multi-system emulator on .NET. Features rerecording and tools for TASing. (Mono runtime)"
+arch=("x86_64")
+url="https://gitlab.com/TASVideos/BizHawk#readme"
+license=("MIT" "custom")
+depends=("glibc" "lsb-release" "mono" "openal")
+optdepends=(
+ "antimicro: to use unsupported controllers as keyboards"
+ "ffmpeg: to use built-in A/V capture, unstable"
+)
+makedepends=("dotnet-sdk")
+provides=("$_providesName=$pkgver")
+source=("https://github.com/TASVideos/BizHawk/releases/download/$pkgver/$_archiveName.zip")
+sha512sums=("cb35924402932f13f3ed7159bd5991c58790287c856db6958f41b631a36c345c5ddea5249d75560ae608c2900c939579fb395989939f99bf11b4b3b9e2e671ae")
+
+package() {
+ cd "$srcdir"
+ mkdir -m 777 -p "$pkgdir/opt/$_providesName"
+ find . -type f -not -name *.sh -exec install -Dm666 "{}" "$pkgdir/opt/$_providesName/{}" \;
+ find . -type f -name *.sh -exec install -Dm777 "{}" "$pkgdir/opt/$_providesName/{}" \;
+}