summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames Groom2020-09-02 09:02:03 +1000
committerJames Groom2020-09-02 09:02:03 +1000
commit92f01aeb412820d152bc8b458483a99974b4392c (patch)
tree70193097f3cfe0cbaee06cfd05f60a2c0bcaf8de /PKGBUILD
parent5ef1f5c13792d8291b8a1bba6c932e8fb3aa42ac (diff)
downloadaur-92f01aeb412820d152bc8b458483a99974b4392c.tar.gz
Add mono-basic to depends, fix permissions on /opt/bizhawk
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d90611d1fa12..eb6b797dc688 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@ pkgname=bizhawk-monort
_providesName=bizhawk
pkgver=2.5
_archiveName="BizHawk-2.5.0"
-pkgrel=1
+pkgrel=2
pkgdesc="A multi-system emulator on .NET. Features rerecording and tools for TASing. (Mono runtime)"
arch=("x86_64")
url="https://gitlab.com/TASVideos/BizHawk#readme"
license=("MIT" "custom")
-depends=("glibc" "lsb-release" "mono" "openal")
+depends=("glibc" "lsb-release" "mono-basic" "openal")
optdepends=(
"antimicro: to use unsupported controllers as keyboards"
"ffmpeg: to use built-in A/V capture, unstable"
@@ -20,7 +20,7 @@ sha512sums=("cb35924402932f13f3ed7159bd5991c58790287c856db6958f41b631a36c345c5dd
package() {
cd "$srcdir"
- mkdir -m 777 -p "$pkgdir/opt/$_providesName"
- find . -type f -not -name *.sh -exec install -Dm666 "{}" "$pkgdir/opt/$_providesName/{}" \;
- find . -type f -name *.sh -exec install -Dm777 "{}" "$pkgdir/opt/$_providesName/{}" \;
+ find . -type d -exec install -D -ggames -m775 -d "$pkgdir/opt/$_providesName/{}" \;
+ find . -type f -not -name *.sh -exec install -D -ggames -m664 "{}" "$pkgdir/opt/$_providesName/{}" \;
+ find . -type f -name *.sh -exec install -D -ggames -m774 "{}" "$pkgdir/opt/$_providesName/{}" \;
}