summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastien Duthil2019-03-27 18:46:04 -0400
committerSebastien Duthil2019-03-27 18:46:04 -0400
commita8b0a022ea823a9acb70ef182bb8ec2ed924f420 (patch)
tree43030e55022738ad46105b9b5efd07875d3cd138 /PKGBUILD
parentda7a94e193f32e237ce83b8c96cebc44baf236de (diff)
downloadaur-a8b0a022ea823a9acb70ef182bb8ec2ed924f420.tar.gz
update to 2.40
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 879ccef93ff7..29221187c0c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# working PKGBUILD for x86
pkgname=blackvoxel
-pkgver=2.31
+pkgver=2.40
pkgrel=2
pkgdesc="Game of automation and programming in a voxel world"
arch=('x86_64')
@@ -12,23 +12,23 @@ url='http://www.blackvoxel.com/'
license=('GPL3')
depends=('glew' 'hicolor-icon-theme' 'mesa' 'sdl')
install="${pkgname}.install"
-source=("${pkgname}_source_2_31.tar.bz2::${url}/dm_download.php?file=139&key=1"
+source=("${pkgname}_source_2_40.tar.bz2::${url}/dm_download.php?file=149&key=1"
"blackvoxel.patch")
-sha256sums=('09d14326031cc81848c59f1c8cf9b53c91c0d36777fb58367c9fb3784f3dd1b4'
+sha256sums=('5e11959a147d888ec7985a10b11fdfef136b14a85bcf9136b16550d64e9dc04c'
'5423a426434498480abe47a18ef10a11d8ee99fca8d2d05aec070814ccd6628a')
prepare() {
# Disable #include glext. Should be already included by glew.
- patch "${srcdir}/${pkgname}_source_2_31/src/main.cpp" "${srcdir}/blackvoxel.patch"
+ patch "${srcdir}/${pkgname}_source_2_40/src/main.cpp" "${srcdir}/blackvoxel.patch"
}
build() {
- cd "${srcdir}/${pkgname}_source_2_31"
+ cd "${srcdir}/${pkgname}_source_2_40"
make blackvoxeldatadir="/usr/share/${pkgname}/"
}
package() {
- cd "${srcdir}/${pkgname}_source_2_31"
+ cd "${srcdir}/${pkgname}_source_2_40"
make install \
specialinstall=true \
DESTDIR="${pkgdir}/" \