summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSebastien Duthil2019-02-03 22:34:46 -0500
committerSebastien Duthil2019-02-03 22:34:51 -0500
commitda7a94e193f32e237ce83b8c96cebc44baf236de (patch)
treea7eae34761a80c5986b4d82af16d5afb71cf054f /PKGBUILD
parentadc1eaf2e4c0bf9cc765dc5b5b3a9a8207181abf (diff)
downloadaur-da7a94e193f32e237ce83b8c96cebc44baf236de.tar.gz
fix compilation
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b561d1cb46b6..879ccef93ff7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,15 +5,22 @@
pkgname=blackvoxel
pkgver=2.31
-pkgrel=1
+pkgrel=2
pkgdesc="Game of automation and programming in a voxel world"
arch=('x86_64')
url='http://www.blackvoxel.com/'
license=('GPL3')
depends=('glew' 'hicolor-icon-theme' 'mesa' 'sdl')
install="${pkgname}.install"
-source=("${pkgname}_source_2_31.tar.bz2::${url}/dm_download.php?file=139&key=1")
-sha256sums=('09d14326031cc81848c59f1c8cf9b53c91c0d36777fb58367c9fb3784f3dd1b4')
+source=("${pkgname}_source_2_31.tar.bz2::${url}/dm_download.php?file=139&key=1"
+ "blackvoxel.patch")
+sha256sums=('09d14326031cc81848c59f1c8cf9b53c91c0d36777fb58367c9fb3784f3dd1b4'
+ '5423a426434498480abe47a18ef10a11d8ee99fca8d2d05aec070814ccd6628a')
+
+prepare() {
+ # Disable #include glext. Should be already included by glew.
+ patch "${srcdir}/${pkgname}_source_2_31/src/main.cpp" "${srcdir}/blackvoxel.patch"
+}
build() {
cd "${srcdir}/${pkgname}_source_2_31"