summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2017-05-07 12:49:28 +0200
committerMartchus2017-05-07 12:49:28 +0200
commit6c16d08fecddb695e21b93d10bdf8b142d496f97 (patch)
tree3d70cd34db8330f6ea8843a952f55883c51220e1 /PKGBUILD
downloadaur-6c16d08fecddb695e21b93d10bdf8b142d496f97.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81c3564c53a1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
+pkgname=blackwidowcontrol-git
+_reponame=${pkgname%-git}
+pkgver=10.e793f18
+pkgrel=1
+pkgdesc='Python script to enable macro keys of the Razer BlackWidow keyboard under GNU/Linux'
+arch=('any')
+license=('GPL')
+depends=('python-pyusb')
+makedepends=('git')
+conflicts=(${_reponame})
+provides=(${_reponame})
+url="https://github.com/Martchus/${_reponame}"
+source=("${_reponame}::${MARTCHUS_GIT_URL_PREFIX:-git://github.com/Martchus}/${_reponame}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${PROJECT_DIR_NAME:-$_reponame}"
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ local _srcdir="$srcdir/${PROJECT_DIR_NAME:-$_reponame}"
+ install -Dm755 "${_srcdir}/blackwidowcontrol.py" "${pkgdir}/usr/bin/blackwidowcontrol"
+ install -Dm644 "${_srcdir}/razer_blackwidow.rules" "${pkgdir}/etc/udev/rules.d/70-razer_blackwidow.rules"
+}