summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRobin Candau2023-04-15 00:41:45 +0200
committerRobin Candau2023-04-15 00:41:45 +0200
commita679df6d9f43016ec8a135d863585c69f548e6e0 (patch)
tree87802e15eb11b130ab67855ca437b1af68b32bea /PKGBUILD
downloadaur-a679df6d9f43016ec8a135d863585c69f548e6e0.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38cb15a23d14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Robin Candau <antiz@archlinux.org>
+
+pkgname=blahaj-git
+_pkgname="${pkgname%-git}"
+pkgver=2.0.0.r12.1431f97
+pkgrel=1
+pkgdesc="Gay sharks at your local terminal - lolcat-like CLI tool (git version)"
+arch=('x86_64')
+url="https://blahaj.queer.software"
+license=('BSD')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+depends=('crystal' 'shards')
+makedepends=('git')
+source=("${_pkgname}::git+https://github.com/GeopJr/BLAHAJ.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "%s.r%s.%s" "$(git describe --tags --abbrev=0 | sed 's/^v//')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build () {
+ cd "${_pkgname}"
+ make build_mt
+}
+
+check () {
+ cd "${_pkgname}"
+ make test
+}
+
+package() {
+ cd "${_pkgname}"
+ install -Dm 755 "bin/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm 644 README.md "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
+}