summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYishen Miao2022-02-13 01:59:32 -0800
committerYishen Miao2022-02-13 01:59:32 -0800
commit4149e1b74eba9e68357b3ee70cc714cf7a05acf6 (patch)
tree1d8b691d70f73729d4ab7deab2d7f5ed0b577698 /PKGBUILD
parent4f0495c5b008742f1e6b47a8183779d8e5a4af6b (diff)
downloadaur-4149e1b74eba9e68357b3ee70cc714cf7a05acf6.tar.gz
Adding dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 32 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 897057edbe02..e7eee3e62cc0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,42 @@
pkgname=blast+
pkgver=2.12.0
-pkgrel=1
+pkgrel=2
pkgdesc="BLAST tool suite from NCBI (blastn, blastp, blastx, psiblast, etc)"
arch=('i686' 'x86_64')
url="http://blast.ncbi.nlm.nih.gov/"
license=('custom')
-depends=('lmdb' 'lzo' 'pcre' 'python')
+depends=('elfutils'
+ 'zlib'
+ 'bzip2'
+ 'lzo'
+ 'zstd'
+ 'pcre'
+ 'gmp'
+ 'nettle'
+ 'krb5'
+ 'mysql'
+ 'freetype'
+ 'python'
+ 'perl'
+ 'sqlite'
+ 'icu'
+ 'expat'
+ 'libxml2'
+ 'libxslt'
+ 'muparser'
+ 'hdf5'
+ 'giflib'
+ 'libjpeg'
+ 'libpng'
+ 'libtiff'
+ 'imagemagick'
+ 'curl'
+ 'mimetic'
+ 'lapack'
+ 'lmdb'
+ 'libuv'
+ 'libssh2')
makedepends=('cpio')
# conflicts with proj on libproj.so
conflicts=('blast' 'blast+-bin' 'ncbi-blast' 'proj')