summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2022-05-28 08:53:14 -0400
committergraysky2022-05-28 08:53:14 -0400
commit91225599861ab0ce9824c914a6fcea52273d99b4 (patch)
tree7c4ea63ddf1d049a87444558ba058848278bbe4a /PKGBUILD
parent26e32370e333d2c86ac2ec1b1814fa80d19d42f5 (diff)
downloadaur-91225599861ab0ce9824c914a6fcea52273d99b4.tar.gz
Update to 4.4.2-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7e7e571ebef7..0d49ffb711ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=bleachbit-cli
_pkgname=bleachbit
pkgver=4.4.2
-pkgrel=1
+pkgrel=2
pkgdesc='Deletes unneeded files to free disk space and maintain privacy. CLI version/no GUI.'
conflicts=($_pkgname)
provides=("bleachbit=${pkgver}")
@@ -17,8 +17,18 @@ arch=(any)
url='https://www.bleachbit.org/'
license=(GPL3)
depends=(python-gobject)
-source=($_pkgname-$pkgver.tar.gz::https://github.com/bleachbit/bleachbit/archive/v$pkgver.tar.gz)
-b2sums=('a44adccdf895ccc5530da71ef8f6eb3232283412851300d2c6c8b8ae5d477bb9f619a14ba1e6d808e825342d82705269523a7ed0ba070fcffb6f02c8ffe0e98e')
+makedepends=(auth-tarball-from-git)
+source=($_pkgname-$pkgver.tar.gz::https://github.com/bleachbit/bleachbit/archive/refs/tags/v$pkgver.tar.gz
+ az0.pgp) # Andrew Ziem <ahz001@gmail.com>
+sha256sums=('6001c864688e36bd8f950c1341923c9347c2373149a9ce98dc26c39023b51997'
+ '1924b4efdb5d74f33b9bc2459dd66a7f1e1e48fef107352fd88ae2b033c04f5a')
+
+prepare() {
+ cd $_pkgname-$pkgver
+ auth-tarball-from-git --keyring ../az0.pgp \
+ --prefix "$_pkgname-$pkgver" --tag v$pkgver \
+ https://github.com/bleachbit/bleachbit ../$_pkgname-$pkgver.tar.gz
+}
package() {
cd $_pkgname-$pkgver