summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2019-11-10 16:41:38 -0500
committergraysky2019-11-10 16:41:38 -0500
commitd9e81b0dc98248f219ceb97c0c4fdf7eb6f0c1a3 (patch)
treef15a98ed82f75ab695fc818d163c954d9249d274 /PKGBUILD
parent28f2d8bbf4e480a461acfc8d9eb252981253b622 (diff)
downloadaur-d9e81b0dc98248f219ceb97c0c4fdf7eb6f0c1a3.tar.gz
Update to 3.0-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4b38f530f7ea..0977df40ba50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=bleachbit-cli
_pkgname=bleachbit
pkgver=3.0
-pkgrel=1
+pkgrel=2
pkgdesc='Deletes unneeded files to free disk space and maintain privacy. CLI version/no GUI.'
conflicts=($_pkgname)
provides=("bleachbit=${pkgver}")
@@ -17,11 +17,17 @@ arch=(any)
url='https://www.bleachbit.org/'
license=(GPL3)
depends=(python2-gobject)
-source=(https://download.bleachbit.org/$_pkgname-$pkgver.tar.bz2)
-sha256sums=('ed18cb522cc375589cc0c94fbfaf6d7ee6fb94a8a1261400252b1ca32b4cdaa2')
+source=(https://download.bleachbit.org/$_pkgname-$pkgver.tar.bz2
+fix.patch::https://github.com/bleachbit/bleachbit/commit/3e3e49d323a228b857307d914fbb90180b4fbb93.patch)
+sha256sums=('ed18cb522cc375589cc0c94fbfaf6d7ee6fb94a8a1261400252b1ca32b4cdaa2'
+ '3565aa5a626b65cf568dd097e23466aede8de8a4a826d928fcf82144c7359260')
prepare() {
cd $_pkgname-$pkgver
+
+ # https://github.com/bleachbit/bleachbit/issues/685
+ patch -Np1 -i ../fix.patch
+
sed -e 's|python|python2|g' -i bleachbit/CLI.py
}