summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorthegala2020-01-21 00:39:40 +0100
committerthegala2020-01-21 00:42:41 +0100
commit4fd71baef3ebdb17bbde8053384f956e611c29dd (patch)
tree96e403519fcfb6b8a7206a989233d118da28e398 /PKGBUILD
downloadaur-4fd71baef3ebdb17bbde8053384f956e611c29dd.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a644eda54ec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: thegala <thegala@disroot.org>
+
+_pkgname=bleachbit
+pkgname=bleachbit-py3-git
+pkgver=r4914.13ee23b7
+pkgrel=1
+pkgdesc='Deletes unneeded files to free disk space and maintain privacy. Python 3 version.'
+url='https://www.bleachbit.org/'
+license=('GPL3')
+source=("${_pkgname}::git+https://github.com/bleachbit/bleachbit.git")
+sha256sums=('SKIP')
+arch=('any')
+depends=('pygtk' 'python-gobject' 'gtk3')
+makedepends=('git')
+conflicts=('bleachbit')
+provides=('bleachbit')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ git checkout origin/py3
+ patch bleachbit.py < ../../python3-patch.patch
+}
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make prefix=/usr DESTDIR="$pkgdir" install
+}