summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2021-01-06 01:12:24 +0100
committerbartus2021-01-06 01:14:49 +0100
commit13c121812cde5c260a62f9665e7aa8c8bfe446c0 (patch)
tree7a93f8a4575e2e0209e6794f91e79118d3269632 /PKGBUILD
parentb065223d5f58ae66650e538681dbfd66f58b4249 (diff)
downloadaur-13c121812cde5c260a62f9665e7aa8c8bfe446c0.tar.gz
Fix build against openvdb:8, pkgdesc refactor
fix #2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c104fd4f6610..8ca6436175c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,10 @@
# shellcheck disable=SC2191 # preserve current _CMAKE_FLAGS initialization.
# Configuration.
-_fragment=${FRAGMENT:-#branch=blender2.7}
+_branch="blender2.7"
+_fragment=${FRAGMENT:-#branch=${_branch}}
[[ -v CUDA_ARCH ]] && _cuda_capability=${CUDA_ARCH}
+_commit_url="https://git.blender.org/gitweb/gitweb.cgi/blender.git/patch"
#some extra, unofficially supported stuff goes here:
((TRAVIS)) && _cuda_capability+=(sm_50 sm_52 sm_60 sm_61 sm_70 sm_75) # Travis memory limit is not enough to build for arch 3.x.
@@ -16,7 +18,7 @@ _fragment=${FRAGMENT:-#branch=blender2.7}
pkgname=blender-2.7
pkgver=2.79b.r71421.e045fe53f1b
pkgrel=3
-pkgdesc="Blender 2.7 branch"
+pkgdesc="Maintnance version of Blenders ${_branch} branch"
arch=('i686' 'x86_64')
url="https://blender.org/"
depends+=('alembic' 'libgl' 'python' 'python-numpy' 'openjpeg2'
@@ -42,6 +44,7 @@ source=("git://git.blender.org/blender.git${_fragment}"
'python3.9.patch' # ::https://git.blender.org/gitweb/gitweb.cgi/blender.git/patch/56d0df51a36fdce7ec2d1fbb7b47b1d95b591b5f
'python3.9_2.patch' # ::https://git.blender.org/gitweb/gitweb.cgi/blender.git/patch/5edba9b42f684bf8b99894bb6988e7f46180e12c
openvdb7.patch
+ openvdb8.patch # ::${_commit_url}/37889011070ff2ec52159690f652238d2b325185
cycles.patch
)
sha256sums=('SKIP'
@@ -56,6 +59,7 @@ sha256sums=('SKIP'
'd106248d55045f5ef913bf6243ad74a76f6282264d9ee4c9b87ec4a3d2e2064b'
'b2a2bc5de8d3b730e49d1f50cb025c1dfdbcb66c58ead573322585b6a887d3a7'
'c4079c4c142516d9cd476f5a3cafddf4068f0950c3c11ea4da9cf999c5ccc1f9'
+ 'edfd784f8497417660c0b9fdc97893fd0d77764d0bc10f4cb92a9082f41bae75'
'd245f02d73bd5b767ffa49d369383d7cd6ae5e57b89c2975a78c1015e1884864')
pkgver() {
@@ -70,7 +74,7 @@ prepare() {
if [ ! -v _cuda_capability ] && grep -q nvidia <(lsmod); then
git -C "$srcdir/blender" apply -v "${srcdir}"/SelectCudaComputeArch.patch
fi
- git -C "$srcdir/blender" apply -v "${srcdir}"/{python3.7,stl_export_iter,python3.{8,9,9_2},openvdb7,cycles}.patch
+ git -C "$srcdir/blender" apply -v "${srcdir}"/{python3.7,stl_export_iter,python3.{8,9,9_2},openvdb{7,8},cycles}.patch
}
build() {