summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoradabru2019-02-01 12:03:33 +0100
committeradabru2019-02-01 12:03:33 +0100
commit7da00e45d4aa86d65de05a7ba33ab30d3d070805 (patch)
treee01bd5e5c7275513a4a0a499db568aa6eac6b706 /PKGBUILD
parenta4105b389779d1b29b731fdcb9e6b632ca405767 (diff)
downloadaur-7da00e45d4aa86d65de05a7ba33ab30d3d070805.tar.gz
pkgver issue
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 609c2b45f75b..39ed4e4986ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adam Brunnmeier <adam.brunnmeier@gmail.com>
pkgname=blender-2.8-bin
pkgver=2.80.190201.8a51af7d1c98
-pkgrel=2
+pkgrel=3
pkgdesc="A fully integrated 3D graphics creation suite"
arch=('i686' 'x86_64')
url="https://www.blender.org"
@@ -21,11 +21,11 @@ md5sums=('SKIP')
_setvars() {
cd "$srcdir"
- local regex="blender-(2.8[^-]*)-([^-]*)-linux-[^-]*-$CARCH.tar.bz2" && [[ $(cat download) =~ $regex ]]
+ local regex="blender-(2.8[^-]*)-([^-]*)-linux-[^-]*-$CARCH.tar.bz2" && [[ $(cat download#$pkgver) =~ $regex ]]
_full=${BASH_REMATCH[0]}
_upstreamversion=${BASH_REMATCH[1]}
_commit=${BASH_REMATCH[2]}
- local regex="$_full.*?<small>([[:alnum:] ]+), ([[:digit:]:]+) - $_commit" && [[ $(cat download) =~ $regex ]]
+ local regex="$_full.*?<small>([[:alnum:] ]+), ([[:digit:]:]+) - $_commit" && [[ $(cat download#$pkgver) =~ $regex ]]
_date=$(date --date="${BASH_REMATCH[1]} ${BASH_REMATCH[2]}" "+%y%m%d")
}