summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoradabru2019-02-07 20:12:40 +0100
committeradabru2019-02-07 20:12:40 +0100
commitbb8c999d650d927f34f7b067c33da4c07980dacc (patch)
treef185b308715a56084b4ea8e4f5cda9ba7c3c594a /PKGBUILD
parentbe4239988eceacb4b421481a7afbdf2af0bea08e (diff)
downloadaur-bb8c999d650d927f34f7b067c33da4c07980dacc.tar.gz
remove hash and http redirect
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2da449a5143c..013dc585ed18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Adam Brunnmeier <adam.brunnmeier@gmail.com>
pkgname=blender-2.8-bin
pkgver=2.80.190206.8c87af74409a
-pkgrel=1
+pkgrel=2
pkgdesc="A fully integrated 3D graphics creation suite"
arch=('i686' 'x86_64')
url="https://www.blender.org"
@@ -18,16 +18,16 @@ conflicts=("${pkgname%-bin}")
# use different url per version to trigger rebuilds when package updates.
# using $pkgver instead of $_inc is not possible (see comments on AUR-website)
_inc=0
-source=("https://builder.blender.org/download#$_inc")
+source=("download$_inc::https://builder.blender.org/download/")
md5sums=('SKIP')
_setvars() {
cd "$srcdir"
- local regex="blender-(2.8[^-]*)-([^-]*)-linux-[^-]*-$CARCH.tar.bz2" && [[ $(cat download#$_inc) =~ $regex ]]
+ local regex="blender-(2.8[^-]*)-([^-]*)-linux-[^-]*-$CARCH.tar.bz2" && [[ $(cat download$_inc) =~ $regex ]]
_full=${BASH_REMATCH[0]}
_upstreamversion=${BASH_REMATCH[1]}
_commit=${BASH_REMATCH[2]}
- local regex="$_full.*?<small>([[:alnum:] ]+), ([[:digit:]:]+) - $_commit" && [[ $(cat download#$_inc) =~ $regex ]]
+ local regex="$_full.*?<small>([[:alnum:] ]+), ([[:digit:]:]+) - $_commit" && [[ $(cat download$_inc) =~ $regex ]]
_date=$(date --date="${BASH_REMATCH[1]} ${BASH_REMATCH[2]}" "+%y%m%d")
}