aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2020-07-30 09:16:43 +0200
committerbartus2020-07-30 09:23:09 +0200
commitc3efeef4224b75b34ab47a0a4bee8a7f908d0bb2 (patch)
tree344298aa03c66d30edade783ef68ec01a2132eb5 /PKGBUILD
parent5ff008238461105780b43b040bfde9c99bff799a (diff)
downloadaur-c3efeef4224b75b34ab47a0a4bee8a7f908d0bb2.tar.gz
Add .shellcheckrc
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a0ef29174a2e..59a480090a85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,9 @@
#!/bin/hint/bash
# Maintainer : bartus <arch-user-repoᘓbartus.33mail.com>
-# shellcheck disable=SC2034,SC2154 # allow unused/unset variables
-# shellcheck disable=SC2191 # preserve current _CMAKE_FLAGS initialization.
# Configuration.
_fragment=${FRAGMENT:-#branch=master}
+# shellcheck disable=SC2206
[[ -v CUDA_ARCH ]] && _cuda_capability=(${CUDA_ARCH})
#some extra, unofficially supported stuff goes here:
@@ -81,7 +80,7 @@ build() {
msg "python version detected: ${_pyver}"
# determine whether we can precompile CUDA kernels
- _CUDA_PKG=`pacman -Qq cuda 2>/dev/null` || true
+ _CUDA_PKG=$(pacman -Qq cuda 2>/dev/null) || true
if [ "$_CUDA_PKG" != "" ] && ! ((DISABLE_CUDA)) ; then
_CMAKE_FLAGS+=( -DWITH_CYCLES_CUDA_BINARIES=ON
-DCUDA_TOOLKIT_ROOT_DIR=/opt/cuda )