aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2022-02-21 16:30:59 +0100
committerbartus2022-02-21 16:32:02 +0100
commit4d1b2a380fa0386ac6d581d7815cfa088d7d0f5b (patch)
tree1cfc2e4a82d6780e3fc46057d2021a565a9fc4df /PKGBUILD
parent698854c28d62b7cc021328bf6d235ac5eac656e1 (diff)
downloadaur-4d1b2a380fa0386ac6d581d7815cfa088d7d0f5b.tar.gz
Drop upstream applied patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ead51f97d905..bb3c289c0b99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,7 +20,7 @@ _fragment=${FRAGMENT:-#branch=master}
((DISABLE_CUDA)) && optdepends+=('cuda: CUDA support in Cycles') || { makedepends+=('cuda') ; ((DISABLE_OPTIX)) || makedepends+=('optix>=7.0'); }
pkgname=blender-develop-git
-pkgver=3.2.r112616.gcbdd5786404
+pkgver=3.2.r112750.g68586d2c183
pkgrel=1
pkgdesc="Development version of Blender (non-conflicting version)"
changelog=blender.changelog
@@ -47,7 +47,6 @@ source=("git://git.blender.org/blender.git${_fragment}"
SelectCudaComputeArch.patch
usd_python.patch #add missing python headers when building against python enabled usd.
embree.patch #add missing embree link.
- openexr3.patch #fix build against openexr:3
)
sha256sums=('SKIP'
'SKIP'
@@ -56,8 +55,7 @@ sha256sums=('SKIP'
'SKIP'
'87c5ee85032bab83510db426ab28f7acfba893aefea2b523f2fd78f3b62c5348'
'333b6fd864d55da2077bc85c55af1a27d4aee9764a1a839df26873a9f19b8703'
- 'd587135fd9b815d60e8b7f48976aa835472922fc8f64c256dc397bfcd3c2642a'
- '5297dc61cc4edcc1d5bad3474ab882264b69d68036cebbd0f2600d9fe21d5a1b')
+ 'd587135fd9b815d60e8b7f48976aa835472922fc8f64c256dc397bfcd3c2642a')
pkgver() {
blender_version=$(grep -Po "BLENDER_VERSION \K[0-9]{3}" "$srcdir"/blender/source/blender/blenkernel/BKE_blender_version.h)
@@ -75,7 +73,7 @@ prepare() {
git -C "$srcdir/blender" apply -v "${srcdir}"/SelectCudaComputeArch.patch
fi
((DISABLE_USD)) || git -C "$srcdir/blender" apply -v "${srcdir}"/usd_python.patch
- git -C "$srcdir/blender" apply -v "${srcdir}"/{embree,openexr3}.patch
+ git -C "$srcdir/blender" apply -v "${srcdir}"/embree.patch
}
build() {