summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2017-09-19 18:21:16 +0200
committerbartus2017-09-19 18:21:16 +0200
commit80c8ce450e89bdf03f873aab83fef97f2dda26a8 (patch)
tree4a1a105b78baf9538ba7127e9388d762a11079bc /PKGBUILD
downloadaur-80c8ce450e89bdf03f873aab83fef97f2dda26a8.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..464a5c24fa2e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# maintained by: bartus szczepaniak <aur@bartus.33mail.com>
+
+name=cubesurfer
+version=1.0
+#fragment="#commit=7e49329 "
+files=(__init__.py mciso*.so mciso*.html)
+pkgname=blender-plugin-${name}
+pkgver=1.0_r22.1d6d9a6
+pkgrel=1
+pkgdesc="IsoSurface mesher addons for Blender ( wrote in Cython )"
+arch=(i686 x86_64)
+url="http://pyroevil.com/category/scripts-addons/cubesurfece/"
+license=('GPL')
+depends=(blender)
+makedepends=(git cython)
+source=("${name}::git+https://github.com/Pyroevil/CubeSurfer.git${fragment}")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${name}
+ printf "${version}_r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${name}
+ sed -i "s|/O2|-O2|" setup64.py
+ sed -i "s|/openmp|-fopenmp|" setup64.py
+ sed -i "s|/fp:fast|-ffast-math|" setup64.py
+
+ python setup64.py build_ext --inplace
+ cp mciso*.so mciso*.html -t ../
+}
+
+package() {
+ cd ${name}
+ addons="$pkgdir/usr/share/blender/$(blender -v | head -n1 | cut -f2 -d ' ')/scripts/addons"
+ install -dm755 ${addons}/${name}
+ for file in ${files[@]} ; do install -m644 ${file} ${addons}/${name}; done
+}
+
+# vim:set ts=2 sw=2 et: