summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHui Yiqun2017-11-30 12:03:32 +0800
committerHui Yiqun2017-11-30 12:03:32 +0800
commitc8284f3843d54f5cd00cfda8122a42bf20fe2120 (patch)
tree382aef18f00b7970faa0db9681be8e82a708f589 /PKGBUILD
downloadaur-blender-plugin-io-three.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ba513ba9b02e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# maintained by: Hui Yiqun <huiyiqun@gmail.com>
+
+name=io-three
+pkgname=blender-plugin-${name}
+pkgver=r88
+pkgrel=1
+pkgdesc="Blender addon for exporting Three.js' ASCII JSON format."
+arch=('any')
+url="https://github.com/mrdoob/three.js/tree/master/utils/exporters/blender"
+license=('MIT')
+depends=('blender')
+makedepends=('git')
+source=("${name}::git+https://github.com/mrdoob/three.js.git#tag=${pkgver}")
+md5sums=('SKIP')
+
+package() {
+ cd ${srcdir}/${name}
+ addons="$pkgdir/usr/share/blender/$(blender -v | head -n1 | cut -f2 -d ' ')/scripts/addons"
+ mkdir -p ${addons}
+ cp -r utils/exporters/blender/addons/io_three ${addons}
+}
+# vim:set ts=2 sw=2 et: