summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2019-03-31 20:54:11 +0200
committerbartus2019-03-31 20:54:11 +0200
commit7bc48593bdc69f63c500f8c88fa7909a8d0c9d2f (patch)
tree004e5191e9fc5c0ac11ef5530bad2f2fde7b7e6b /PKGBUILD
parentb31475d4c5a9e2c3c649bf11aef2619b0bb6a12e (diff)
downloadaur-7bc48593bdc69f63c500f8c88fa7909a8d0c9d2f.tar.gz
pop version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 11df00fc7c4f..51bd556f43c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _blender=$(pacman -Sddp --print-format %v blender|grep -oP '(?<=\:)[[:digit:]]{1
_name="luxcorerender"
pkgname=blender-plugin-${_name}
-pkgver=2.1
+pkgver=2.2alpha1
epoch=1
pkgrel=1
pkgdesc="LuxCoreRender exporter plugin for Blender"
@@ -13,12 +13,12 @@ url="http://www.luxrender.net/"
license=('GPL')
depends=(blender luxcorerender)
conflicts=(luxblend25 luxblend25-hg)
-source=("https://github.com/LuxCoreRender/BlendLuxCore/archive/blendluxcore_v2.1.tar.gz")
-md5sums=('ddb395698d0603100f868ddb6dd739d6')
+source=("https://github.com/LuxCoreRender/BlendLuxCore/archive/blendluxcore_v${pkgver}.tar.gz")
+md5sums=('62c4b9d42cee2d3d7ba0c3442ba9ccc9')
package() {
install -d -m755 ${pkgdir}/usr/share/blender/${_blender}/scripts/addons
- cp -a ${srcdir}/BlendLuxCore-blendluxcore_v2.1 ${pkgdir}/usr/share/blender/${_blender}/scripts/addons/${_name}
+ cp -a ${srcdir}/BlendLuxCore-blendluxcore_v${pkgver} ${pkgdir}/usr/share/blender/${_blender}/scripts/addons/${_name}
# change the search path in exporter so it finds pylux in its new location :(previous solution was much better, what happen to blendlux )
#sed -i 's|from.*import pylux|import pylux|' "$pkgdir/usr/share/blender/$_blender/scripts/addons/luxrender/outputs/pure_api.py"
for file in `grep -rl import\ pyluxcore ${pkgdir}` ; do sed -i 's/from .* import pyluxcore/import pyluxcore/g' $file; done