summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristoph Brill2017-08-30 22:05:13 +0200
committerChristoph Brill2017-08-30 22:05:13 +0200
commit4f85405b4d70a61d66d7a1b502acf0b6f4200abd (patch)
treedb7c33675c867b2e049e8fbc860a92e1e36526dc /PKGBUILD
downloadaur-4f85405b4d70a61d66d7a1b502acf0b6f4200abd.tar.gz
Add package blender-plugin-meshlint-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..668661b7cb27
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Christoph Brill <egore911@gmail.com>
+pkgname=blender-plugin-meshlint-git
+pkgver=1.0_r8ab0870
+pkgrel=1
+pkgdesc="A Blender Addon to help you keep your meshes clean and lint-free, like a spell-checker for your meshes."
+arch=(any)
+url="https://github.com/rking/meshlint"
+license=('GPL')
+depends=(blender)
+makedepends=(git)
+source=("meshlint::git+https://github.com/rking/meshlint.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd meshlint
+ printf "1.0_r%s" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd meshlint
+ addons="$pkgdir/usr/share/blender/$(blender -v | head -n1 | cut -f2 -d ' ')/scripts/addons"
+ install -dm755 ${addons}/meshlint
+ install -m644 meshlint.py ${addons}/meshlint
+}