summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2018-05-21 13:52:04 +0200
committerbartus2018-05-21 13:52:04 +0200
commit7c04f5e5c30f33f11bfecd7fcac54a058964ef34 (patch)
treeeacf14119d322b061b0008356e182d578beb4da5 /PKGBUILD
parent19ea2b2cf4ce8f380d95379b6319b76236f1d260 (diff)
downloadaur-7c04f5e5c30f33f11bfecd7fcac54a058964ef34.tar.gz
use expac
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6b4fb5bc9b1f..acce54645cce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,10 @@
# Maintainer: bartus <szczepaniak.bartek+aur@gmail.com>
# original maintainer : Fabien Devaux <fdev31@gmail.com>
+_blender=$(expac %v blender|grep -oP '(?<=\:)[[:digit:]]{1}\.[[:digit:]]{2}(?=\.)')
+
pkgname=blender-plugin-miratools
-pkgver=r651.0dfd4c1 # commit-num.commit-hash
+pkgver=r688.6f50f8d # commit-num.commit-hash
pkgrel=1
pkgdesc="Modern modeling and retopology tools"
url="https://github.com/mifth/mifthtools/wiki/Mira-Tools"
@@ -10,7 +12,7 @@ license=("GPL")
arch=('any')
depends=('blender')
groups=('blender')
-makedepends=('git')
+makedepends=('expac' 'git')
source=("${pkgname}::git+https://github.com/mifth/mifthtools.git")
md5sums=('SKIP')
@@ -20,7 +22,7 @@ pkgver() {
}
package() {
- addons="$pkgdir/usr/share/blender/$(blender -v | head -n1 | cut -f2 -d ' ')/scripts/addons/"
+ addons="$pkgdir/usr/share/blender/${_blender}/scripts/addons/"
install -dm755 ${addons}/${name}
cp -a ${srcdir}/${pkgname}/blender/addons/* ${addons}/${name}
}