summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdam Goldsmith2016-07-01 18:17:22 -0400
committerAdam Goldsmith2016-07-01 18:17:22 -0400
commit173cf6c8a548a58bf8ae69770a4b0c70d66c84c8 (patch)
tree6e079a01ba0461e905ec68c31f15873d5a1edf8e /PKGBUILD
downloadaur-173cf6c8a548a58bf8ae69770a4b0c70d66c84c8.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5fc804b661de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
+
+pkgname=blendercam-git
+pkgver=r494.d8c1696
+pkgrel=1
+pkgdesc="An open source solution for artistic CAM"
+license=("GPL2")
+arch=(any)
+depends=('blender' 'python' 'python-shapely' 'python-numpy')
+url="http://blendercam.blogspot.com/"
+install="blendercam-git.install"
+source=("git+https://github.com/vilemnovak/blendercam.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd blendercam
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $srcdir/blendercam
+ mkdir -p "$pkgdir/usr/share/blender/2.77/"
+ cp -r scripts "$pkgdir/usr/share/blender/2.77/"
+}