summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcapezotte2021-05-15 10:08:13 -0300
committercapezotte2021-05-15 10:08:13 -0300
commit100c1e4595439583bc5666c311aed6c28f7a52a5 (patch)
treebb946a0cf84849a4ad751a9ac012598e1103e066 /PKGBUILD
parent34772eff834414cdfe9a9e1e68b367cb9f2d1a93 (diff)
downloadaur-100c1e4595439583bc5666c311aed6c28f7a52a5.tar.gz
Add suport for ble.sh's new update mechanism
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 65659fbdf7fa..23024f9867d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,39 @@
# Maintainer: capezotte (carana2099 ob gmail at com)
+# Contributor: Seto (Github: huresche)
+# Contributor: Koichi Murase (Github: akinomyoga)
pkgname=blesh-git
_pkgname=ble.sh
-pkgdesc="A replacement for bash's line editor with advanced features"
-pkgver=r1486.0506df2
+pkgdesc="Custom bash line editor with enhanced features"
+pkgver=0.4.0_devel3.r1508.0bc2660
pkgrel=1
license=(BSD)
url='https://github.com/akinomyoga/ble.sh'
-depends=(bash)
-makedepends=(bash awk make)
+depends=(bash awk sed)
+makedepends=(bash awk sed make git)
arch=(any)
-source=('git+https://github.com/akinomyoga/ble.sh.git')
-md5sums=('SKIP')
+source=("git+$url" "git+${url/%.sh/sh-contrib}" 'blesh-update.sh')
+md5sums=('SKIP'
+ 'SKIP'
+ 'c454a07ba7b4912b0f1bfa91f015b379')
install=blesh.install
pkgver() {
cd "$_pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "%s.r%s.%s" \
+ "$(sed -n 's/-/_/g;s/^FULLVER[[:space:]]*:=[[:space:]]*//p' GNUmakefile)" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
}
prepare() {
cd "$_pkgname"
- git submodule init
+ git submodule update --init --recursive
}
package() {
+ # Makes ble-update call an AUR helper
+ install -Dm755 blesh-update.sh "$pkgdir"/usr/share/blesh/lib/_package.sh
cd "$_pkgname"
make install DESTDIR="$pkgdir" PREFIX=/usr
}