summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJose Lopes2021-12-31 14:47:52 +0000
committerJose Lopes2021-12-31 14:47:52 +0000
commitefc6043170d1521f9b997840821b22505560d7ae (patch)
tree117766885fe819d1965bf419ea6921fefeebb864 /PKGBUILD
parent038b894975e24314d68d9683867891465098b47f (diff)
downloadaur-efc6043170d1521f9b997840821b22505560d7ae.tar.gz
Add patch to fix build for python 3.10; Fix PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index af6c50d20b0e..0acbdcc0440f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=blink-qt
pkgname=blink
pkgver=5.1.8
-pkgrel=1
+pkgrel=2
pkgdesc='Fully featured, easy to use SIP client with a Qt based UI'
arch=('aarch64' 'x86_64')
url='https://icanblink.com'
@@ -25,8 +25,16 @@ depends=(
)
optdepends=('x11vnc: for screen sharing')
_commit=a54013c11bee521a224c81c021e1bf453320ca79 # 5.1.8
-source=("$pkgname-$pkgver.tar.gz::https://github.com/AGProjects/blink-qt/archive/$_commit.tar.gz")
-b2sums=('7b0feab275f4c2abecb86784ce134aad7ef0129fc61aad7ef3ceb4ead61f1f7b0959e13faa4bfcb0705341e3d101034371f7714a14996e046ceffc96a3bbc878')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/AGProjects/${_pkgname}/archive/$_commit.tar.gz" 'fix_MutableSet.patch')
+b2sums=(
+ '7b0feab275f4c2abecb86784ce134aad7ef0129fc61aad7ef3ceb4ead61f1f7b0959e13faa4bfcb0705341e3d101034371f7714a14996e046ceffc96a3bbc878'
+ '1560c07c3ca8fecc1a47f793b06150cb3c4375a96f79e667202f13830d041cd318b024c6062e27e9a8f92c077b77a5095e0741a25b81a69378457959e1e4954d'
+)
+
+prepare() {
+ cd $_pkgname-$_commit
+ patch --forward --strip=1 --input="${srcdir}/fix_MutableSet.patch"
+}
build() {
cd $_pkgname-$_commit
@@ -34,7 +42,7 @@ build() {
}
package() {
- cd _pkgname-$_commit
+ cd $_pkgname-$_commit
python3 setup.py install --root="$pkgdir/" --optimize=1 --skip-build
# license