summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authortuxzz2022-05-04 15:59:48 +0800
committertuxzz2022-05-04 15:59:48 +0800
commit5d5af3e84080ef0af1fa2b392a532d70ca31fb71 (patch)
treee1e8f74cc828b2e856f1c14537881b032d3493b4 /PKGBUILD
parent44130ae2740a201561a00f8602144954b6421cc5 (diff)
downloadaur-blis-cblas.tar.gz
blis 0.9.0, cblas 3.10.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 16 insertions, 34 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0d0bf215f55a..3c4f68d03e45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Maintainer: tuxzz <dorazzsoft@gmail.com>
+# Contributer: jclds139 <codling@umich.edu>
pkgname=blis-cblas
-pkgver=0.7.0
-_blasver=3.9.0
-pkgrel=0
+pkgver=0.9.0
+_blasver=3.10.0
+pkgrel=1
pkgdesc="BLAS-like Library Instantiation Software Framework (providing blas and cblas, with pthreads support, particularly recommended for AMD Zen CPUs)"
arch=('i686' 'x86_64')
license=('custom')
@@ -13,14 +14,14 @@ provides=('blis')
conflicts=('blis' 'blas' 'cblas')
provides=("blas=${_blasver}" "cblas=${_blasver}")
source=(
-"$pkgname::git+https://github.com/flame/blis.git#commit=943a21def0bedc1732c0a2453afe7c90d7f62e95"
+"${pkgname%-cblas}::https://github.com/flame/blis/archive/refs/tags/${pkgver}.tar.gz"
"cblas_f77.h"
"cblas_mangling.h"
"cblas_test.h"
"cblas.h"
)
sha1sums=(
-'SKIP'
+'c5ff9b0437edc1f93ad30fcdd633c0a276165b7e'
'SKIP'
'SKIP'
'SKIP'
@@ -29,21 +30,9 @@ sha1sums=(
options=('staticlibs' '!emptydirs')
build() {
- cd "${pkgname}"
- unset CC CXX CFLAGS CXXFLAGS
- export CC="gcc"
- export CXX="g++"
- export CFLAGS="-pipe -Ofast -fno-plt -ftree-vectorize -flto -falign-functions=32 -fno-semantic-interposition -fipa-pta -fdevirtualize-at-ltrans -floop-nest-optimize -floop-strip-mine -floop-interchange -fgraphite-identity"
- export CXXFALGS=${CFLAGS}
+ cd "${pkgname%-cblas}-${pkgver}"
- export BLIS_JC_NT=1
- export BLIS_PC_NT=1
- export BLIS_IC_NT=1
- export BLIS_JR_NT=1
- export BLIS_IR_NT=1
- export OMP_NUM_THREADS=1
- export OPENBLAS_NUM_THREADS=1
- export MKL_NUM_THREADS=1
+ export BLIS_NUM_THREADS=`nproc`
export nt_use=1
# static build is necessary for some packages and programs (e. g. GAMESS)
@@ -52,35 +41,28 @@ build() {
}
check() {
- cd "${pkgname}"
+ cd "${pkgname%-cblas}-${pkgver}"
- export BLIS_JC_NT=1
- export BLIS_PC_NT=1
- export BLIS_IC_NT=1
- export BLIS_JR_NT=1
- export BLIS_IR_NT=1
- export OMP_NUM_THREADS=1
- export OPENBLAS_NUM_THREADS=1
- export MKL_NUM_THREADS=1
+ export BLIS_NUM_THREADS=`nproc`
export nt_use=1
make check
}
package() {
- cd "${pkgname}"
+ cd "${pkgname%-cblas}-${pkgver}"
make DESTDIR="${pkgdir}" install
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE"
install -Dm644 ${srcdir}/cblas_{f77,mangling,test}.h "${pkgdir}/usr/include/"
install -Dm644 ${srcdir}/cblas.h "${pkgdir}/usr/include/"
-
+
cd ${pkgdir}/usr/lib
# BLAS
ln -sv libblis.so libblas.so
- ln -sv libblis.so libblas.so.3
- ln -sv libblis.so libblas.so.3.9.0
+ ln -sv libblis.so libblas.so.${_blasver%.*.*}
+ ln -sv libblis.so libblas.so.${_blasver}
# CBLAS
ln -sv libblis.so libcblas.so
- ln -sv libblis.so libcblas.so.3
- ln -sv libblis.so libcblas.so.3.9.0
+ ln -sv libblis.so libcblas.so.${_blasver}
+ ln -sv libblis.so libcblas.so.${_blasver%.*.*}
}