summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2018-01-05 21:23:45 +0100
committerhaawda2018-01-05 21:23:45 +0100
commit0f570e5b62b82157e0d1c1432f3dde2d8761b06f (patch)
tree2c04f3fbebca073309fc7d02366f4d5e9003eae8 /PKGBUILD
parentb02470b2d105d81bf7fdc98eae446d33030acbb3 (diff)
downloadaur-0f570e5b62b82157e0d1c1432f3dde2d8761b06f.tar.gz
upstream changed build system, patch needed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 11 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b71e7b30a605..248224a49f38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,20 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=blis-git
-pkgver=0.2.2.126.g0084531d
+pkgver=0.2.2.137.g0b3ca3cf
pkgrel=1
pkgdesc="BLAS-like Library Instantiation Software framework by the Science of High-Performance Computing Group"
-arch=('i686' 'x86_64')
-license=('BSD')
+arch=('x86_64')
+license=('custom:BSD')
depends=('glibc')
makedepends=('python2')
url='https://github.com/flame/blis'
#provides=('blas=3.5.0' 'cblas')
#conflicts=('blas' 'cblas')
options=('!makeflags' '!emptydirs')
-source=("git+https://github.com/flame/blis.git")
-md5sums=('SKIP')
+source=("git+https://github.com/flame/blis.git" fpic.patch)
+md5sums=('SKIP'
+ 'e6e4efeb173915d038d62cb76f58c4bb')
pkgver() {
cd "${pkgname%-git}"
@@ -22,25 +23,22 @@ pkgver() {
}
prepare() {
-# Determine appropriate BLIS kernel for CPU
- cd "${pkgname%-git}/build/auto-detect"
- _bliskernel="$(./auto-detect.sh)"
- cd ..
- sed -i '1s+python$+python2+' flatten-headers.py
+ cd "${pkgname%-git}"
+ patch -Np1 < "$srcdir"/fpic.patch
}
build() {
cd "${pkgname%-git}"
- ./configure -p "${pkgdir}/usr" "${_bliskernel}"
+ CFLAGS+=" -fPIC" ./configure -p "${pkgdir}/usr" x86_64
make BLIS_ENABLE_DYNAMIC_BUILD:=yes
}
package() {
- mkdir -p "${pkgdir}/etc/profile.d"
+ install -d "${pkgdir}"/etc/profile.d
cd "${pkgname%-git}"
make install BLIS_ENABLE_DYNAMIC_BUILD:=yes
# ln -s "/usr/lib/libblis.so" "${pkgdir}/usr/lib/libblas.so"
# ln -s "/usr/lib/libblis.so" "${pkgdir}/usr/lib/libcblas.so"
printf "# Set blis loop threading environment variables\\n# Please customize for your hardware and application\\n\\nexport BLIS_IR_NT=1\\nexport BLIS_JR_NT=1\\nexport BLIS_IC_NT=1\\nexport BLIS_JC_NT=1" > "${pkgdir}/etc/profile.d/blis.sh"
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}