summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2018-07-02 22:02:12 +0200
committerhaawda2018-07-02 22:02:12 +0200
commit923f6d1af4beac6b3dbbd92b4d6ba31bfc003dd7 (patch)
treec10ad9de1842ee5a4e20f45b2ab1309e89934886 /PKGBUILD
parent2b04bcc1460ffd31f934ebe0646a0e5618fc76dd (diff)
downloadaur-923f6d1af4beac6b3dbbd92b4d6ba31bfc003dd7.tar.gz
copy filey manually to the package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 992d24547b32..d998b5b49fd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,20 @@
pkgname=blis-git
pkgver=0.3.2.60.g3f387ca3
-pkgrel=1
+pkgrel=2
pkgdesc="BLAS-like Library Instantiation Software framework by the Science of High-Performance Computing Group"
arch=('x86_64')
license=('custom:BSD')
depends=('glibc')
makedepends=('python2')
+conflicts=('blis')
+provides=('blis')
url='https://github.com/flame/blis'
options=('!buildflags' '!emptydirs')
-source=("git+https://github.com/flame/blis.git" fpic.patch)
-md5sums=('SKIP'
- 'e6e4efeb173915d038d62cb76f58c4bb')
+source=("git+https://github.com/flame/blis.git" fpic.patch blis_profile.sh)
+sha512sums=('SKIP'
+ 'e9b7558a8c703570089ba1923d03444ec0a63c9d10cc8931dc9a19a0faa5553eecbae5af9ca4923f425259173fc7958e852c6ef9c9375f83b5d21c4634e088b5'
+ 'cb53fa1f8c540062d4d55b4b91c787a821c563ea0bdb4e37f1db08869c320132a493e6b55f5d876418d56ad5b4f1dc5553f871862418393614e160dd1329ec9e')
pkgver() {
cd "${pkgname%-git}"
@@ -34,9 +37,9 @@ build() {
package() {
install -d "${pkgdir}"/etc/profile.d
cd "${pkgname%-git}"
- make install BLIS_ENABLE_DYNAMIC_BUILD:=yes
-# ln -s "/usr/lib/libblis.so" "${pkgdir}/usr/lib/libblas.so"
-# ln -s "/usr/lib/libblis.so" "${pkgdir}/usr/lib/libcblas.so"
- printf "# Set blis loop threading environment variables\\n# Please customize for your hardware and application\\n\\nexport BLIS_IR_NT=1\\nexport BLIS_JR_NT=1\\nexport BLIS_IC_NT=1\\nexport BLIS_JC_NT=1" > "${pkgdir}/etc/profile.d/blis.sh"
- install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+ # make install installs nothing, do it manually
+ install -Dm644 ./include/x86_64/blis.h "$pkgdir"/usr/include/blis/blis.h
+ install -Dm644 ./lib/x86_64/libblis.a "$pkgdir"/usr/lib/libblis.a
+ install -Dm755 "$srcdir"/blis_profile.sh "$pkgdir"/etc/profile.d/blis.sh
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}