summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdrian Perez de Castro2017-12-19 11:07:18 +0200
committerAdrian Perez de Castro2017-12-19 11:07:18 +0200
commitbbfdd5cd34dc8fd58b6736be9e2a246c7a593985 (patch)
treeb189818bdc71f729d513b062b1693248f9a92326 /PKGBUILD
parentcf4e44a9a43caa0876e876d92dfed6fef31c5c4a (diff)
downloadaur-bbfdd5cd34dc8fd58b6736be9e2a246c7a593985.tar.gz
Fix build, now upstream is using CMake
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 15 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c44d2690eb30..daee46e5529b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Yamakaky <yamakaky@yamaworld.fr>
pkgname=bloaty-git
-pkgver=0.0.0.r68.g263f2ef
-pkgrel=2
+pkgver=0.0.0.r232.g340c0a7
+pkgrel=1
pkgdesc="A size profiler for binaries"
arch=("x86_64" "x86")
url="https://github.com/google/bloaty"
license=("Apache")
-makedepends=("git" "gcc")
+depends=('gcc-libs')
+makedepends=('git' 'cmake')
source=("git+https://github.com/google/bloaty")
md5sums=("SKIP")
@@ -16,10 +17,19 @@ pkgver() {
}
build() {
- cd "$srcdir/bloaty"
+ rm -rf "${srcdir}/build"
+ mkdir "${srcdir}/build"
+ cd "${srcdir}/build"
+ cmake -G 'Unix Makefiles' \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ "${srcdir}/bloaty"
make
}
package() {
- install -D "$srcdir/bloaty/bloaty" "$pkgdir/usr/bin/bloaty"
+ cd "${srcdir}/build"
+ install -Dm755 "${srcdir}/build/bloaty" \
+ "${pkgdir}/usr/bin/bloaty"
+ install -Dm644 "${srcdir}/bloaty/README.md" \
+ "${pkgdir}/usr/share/doc/${pkgname}/README.md"
}