summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSam Bazley2019-10-18 00:13:42 +0100
committerSam Bazley2019-10-18 00:13:42 +0100
commit7b886305d6929ac1ea824fb335479a9f57223d61 (patch)
tree9d5e78c2220cb7542499a648da9422b0d17e0da5 /PKGBUILD
downloadaur-7b886305d6929ac1ea824fb335479a9f57223d61.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2674065581b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+#Maintainer: Sam Bazley <sambazley@fastmail.com>
+
+module=constwidth
+
+pkgname=blockbar-${module}-git
+pkgver=20191017024640
+pkgrel=1
+pkgdesc="Module for blockbar that prevents the block's width from changing"
+arch=("i686" "x86_64")
+url="https://gitlab.com/sambazley/blockbar-${module}"
+license=("ZLIB")
+makedepends=()
+depends=("blockbar")
+source=("git+https://gitlab.com/sambazley/blockbar-${module}.git")
+md5sums=("SKIP")
+
+pkgver() {
+ cd blockbar-${module}
+ git show -s --format=%ci HEAD | cut -d' ' -f1-2 | sed -r 's/[^0-9]//g'
+}
+
+build() {
+ cd "${srcdir}/blockbar-${module}"
+ make
+}
+
+package() {
+ cd "${srcdir}/blockbar-${module}"
+ make PREFIX="$pkgdir/usr" install
+}