summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGuillaume Horel2023-05-30 13:03:03 -0400
committerGuillaume Horel2023-05-30 13:03:03 -0400
commit7f4280f0f7e4a8f517d41263bac8bf728f28645b (patch)
tree8c8a95badba1409177f415f33235a2b3cd31e0cb /PKGBUILD
parent78cb2966687ea9ddfa33511cb91b11b08a7911e1 (diff)
downloadaur-7f4280f0f7e4a8f517d41263bac8bf728f28645b.tar.gz
bump to 3.20.2.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8273a7421bc9..475f150220f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=blpapi_cpp
-pkgver=3.16.1.1
+pkgver=3.20.2.1
pkgrel=1
pkgdesc="Bloomberg API C++ SDK (BLPAPI)."
arch=("x86_64")
@@ -9,14 +9,15 @@ url="https://www.bloomberglabs.com/"
license=('custom')
depends=('glibc')
source=("https://bcms.bloomberg.com/BLPAPI-Generic/blpapi_cpp_$pkgver-linux.tar.gz")
-sha256sums=('d8e0db4b4754f725c052084c09c07e3d111f655fd7079762f23ecc05d6402afd')
+sha256sums=('f23e275d809995b4ed21aa0071ac61350342697928b4da4f55016c619f28facd')
package() {
- cd "$srcdir/${pkgname}_$pkgver"
+ cd "${pkgname}_$pkgver"
install -Dm755 "Linux/libblpapi3_64.so" "$pkgdir/usr/lib/libblpapi3_64.so"
install -Dm644 include/* -t "$pkgdir/usr/include"
- install -Dm644 doc/html/* -t "$pkgdir/usr/share/doc/$pkgname/html"
- install -Dm644 doc/ChangeLog.txt "pkgdir/usr/share/doc/ChangeLog.txt"
+ install -Dm644 doc/html/*.{js,html,png,css} -t "$pkgdir/usr/share/doc/$pkgname/html"
+ install -Dm644 doc/html/search/*.{js,html,png,css} -t "$pkgdir/usr/share/doc/$pkgname/html/search"
+ install -Dm644 doc/ChangeLog.txt "$pkgdir/usr/share/doc/ChangeLog.txt"
# copy license to proper directory
install -Dm644 License.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"