summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052023-12-04 13:15:36 +0800
committerzxp198210052023-12-04 13:15:36 +0800
commitcab3a390d381ccd5ed3c827aae9e13c6aa3d4ce6 (patch)
tree263024ee300b5b1e5f178c1c4f5bcfd82ef7dd05 /PKGBUILD
parent543d6410bba32b6b2bc10af5dd93db0310565848 (diff)
downloadaur-cab3a390d381ccd5ed3c827aae9e13c6aa3d4ce6.tar.gz
update to 1.12.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 29 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5fc23a24ff61..e4a79cfde320 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,40 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname=bluebubbles-bin
_pkgname=BlueBubbles
-pkgver=1.12.4
-pkgrel=3
+pkgver=1.12.6
+pkgrel=1
pkgdesc="A cross-platform app ecosystem, bringing iMessage to Android, PC (Windows, Linux, & even macOS), and Web!"
-arch=('aarch64' 'x86_64')
+arch=(
+ 'aarch64'
+ 'x86_64'
+)
url="https://bluebubbles.app/"
-_githuburl="https://github.com/BlueBubblesApp/bluebubbles-app"
+_ghurl="https://github.com/BlueBubblesApp/bluebubbles-app"
license=('Apache')
provides=("${pkgname%-bin}=${pkgver}")
conflicts=("${pkgname%-bin}")
-depends=('glib2' 'libepoxy' 'webkit2gtk-4.1' 'gcc-libs' 'at-spi2-core' 'gdk-pixbuf2' 'cairo' 'mpv' \
- 'harfbuzz' 'glibc' 'pango' 'libdbusmenu-glib' 'libnotify' 'libappindicator-gtk3' 'gtk3' 'libsoup3')
-makedepends=('gendesk')
-source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.tar::${_githuburl}/releases/download/v${pkgver}%2B58/${pkgname%-bin}-linux-aarch64.tar")
-source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.tar::${_githuburl}/releases/download/v${pkgver}%2B58/${pkgname%-bin}-linux-x86_64.tar")
-sha256sums_aarch64=('63fc7c8d87eee6086c4bda557aa0e97893c643aecf95ea41ce5a86ea30a09379')
-sha256sums_x86_64=('616ab5cfd458cb3ba1a8fea163443e686173a6312d806e42a08e920adcfce97b')
+depends=(
+ 'libepoxy'
+ 'webkit2gtk-4.1'
+ 'at-spi2-core'
+ 'gdk-pixbuf2'
+ 'cairo'
+ 'mpv'
+ 'harfbuzz'
+ 'pango'
+ 'libdbusmenu-glib'
+ 'libnotify'
+ 'libappindicator-gtk3'
+ 'gtk3'
+ 'libsoup3'
+)
+makedepends=(
+ 'gendesk'
+)
+source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.tar::${_ghurl}/releases/download/v${pkgver}%2B60/${pkgname%-bin}-linux-aarch64.tar")
+source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.tar::${_ghurl}/releases/download/v${pkgver}%2B60/${pkgname%-bin}-linux-x86_64.tar")
+sha256sums_aarch64=('374710f68ee71e131346aee9d29282fe1fd21d6f4d0c545463133ea3bce55047')
+sha256sums_x86_64=('916ea47eaab1c02d7324150f0bb46479655c23b8fcf070faee38cbb75e97ad61')
build() {
gendesk -f -n -q --icon "${pkgname%-bin}" --categories "Network" --name "${_pkgname}" --exec "${pkgname%-bin} %U"
}