summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHugo Osvaldo Barrera2015-06-05 16:39:53 -0300
committerHugo Osvaldo Barrera2015-06-09 01:42:55 -0300
commit495fa00c019388164e717659d51f96d450217f1a (patch)
tree2fa9854650283c47df9e5f6c8db30849f9dc73d3 /PKGBUILD
downloadaur-495fa00c019388164e717659d51f96d450217f1a.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7029531a0d52
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Martin Wimpress <code@flexion.org>
+
+_pkgname=blueman
+pkgname=${_pkgname}-git
+pkgver=2.0.r2.g9bd5a20
+pkgrel=1
+pkgdesc="A GTK+ Bluetooth Manager (BlueZ 5) - git"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="https://github.com/blueman-project/blueman"
+depends=('bluez' 'dbus-glib' 'gconf' 'gtk3' 'notification-daemon' 'libnotify'
+ 'polkit' 'python-cairo' 'python-dbus' 'python-gobject'
+ 'python-pybluez' 'startup-notification')
+optdepends=('dnsmasq: DHCP server for Network Access Point'
+ 'pulseaudio: for some audio support')
+makedepends=('cython' 'git' 'intltool' 'libtool')
+conflicts=('blueman' 'blueman-bzr')
+provides=('blueman')
+source=("${pkgname}"::"git+https://github.com/blueman-project/${_pkgname}.git")
+sha1sums=('SKIP')
+install=${pkgname}.install
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib/${_pkgname} \
+ --with-gtk=3.0 \
+ --disable-hal \
+ --disable-sendto \
+ --disable-static
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="${pkgdir}" install
+}