summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPaulo Matias2023-04-11 18:26:16 -0300
committerPaulo Matias2023-04-11 18:26:16 -0300
commit05ae6971fcabfe1fdfee1f483dcf17a711d97901 (patch)
tree2500d619f0c24d8d247470b20f2f1448cf5dd375 /PKGBUILD
parentadff1e2e03c96753a24cd8cce41026194ed4f0e4 (diff)
downloadaur-05ae6971fcabfe1fdfee1f483dcf17a711d97901.tar.gz
perez.aron's faster pkgrel computation
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 500799c53d1b..d6ba2361a4d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ makedepends=('git' 'gperf' 'ghc' 'tcl' 'texlive-latexextra' 'texlive-fontsextra'
optdepends=('tcl: bluesim and bluetcl')
# workaround for pkgrel overwritten on regen (by TkG)
# rebuild whenever some haskell depend is rebuilt
-eval pkgrel=$(LC_ALL=C pacman -Si ${depends[@]} | awk '/Version/{sum+=substr($0,match($0,/[^-]+$/))}END{print sum}')
+eval pkgrel=$(pacman -Q ${depends[@]} | cut -d" " -f2 | cut -d"-" -f2 | awk '{sum+=$0}END{print sum}')
source=("git+https://github.com/b-lang-org/bsc.git"
"git+https://github.com/SRI-CSL/yices2.git")
sha256sums=('SKIP'