summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPaulo Matias2020-04-20 18:03:41 -0300
committerPaulo Matias2020-04-20 18:03:41 -0300
commit61678399bd801be60fdc0f4934c8ced7380b12d9 (patch)
tree99388c225e0f95bf522e6056852e27412f6198e8 /PKGBUILD
parent7f385cf8ef0b3f34192066102cef2b2ab5f3cc14 (diff)
downloadaur-61678399bd801be60fdc0f4934c8ced7380b12d9.tar.gz
Bluewish was removed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0873459ea77b..33cac31e8d39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,9 +9,8 @@ arch=('x86_64')
url='https://github.com/B-Lang-org/bsc'
license=('BSD')
depends=('haskell-old-time' 'haskell-syb' 'haskell-regex-compat' 'haskell-split')
-makedepends=('git' 'gperf' 'ghc' 'tk')
-optdepends=('tcl: bluesim and bluetcl'
- 'tk: bluewish')
+makedepends=('git' 'gperf' 'ghc')
+optdepends=('tcl: bluesim and bluetcl')
source=("git+https://github.com/b-lang-org/bsc.git")
sha256sums=('SKIP')
_prefix="/opt/bluespec"
@@ -41,7 +40,7 @@ package() {
install -d "${pkgdir}/usr/bin"
local _prog
- for _prog in bsc bluetcl bluewish; do
+ for _prog in bsc bluetcl; do
sed -i "s,^BINDIR=.*$,BINDIR=${_prefix}/bin," "${pkgdir}${_prefix}/bin/${_prog}"
ln -s "${_prefix}/bin/${_prog}" "${pkgdir}/usr/bin"
done