summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPaulo Matias2021-11-08 11:17:06 -0300
committerPaulo Matias2021-11-08 11:17:06 -0300
commit66209bb697e7fedaa8998e472ec7dddc60a31d26 (patch)
tree6c1d3625c01b82a5bc76361b7cd373e7131457f3 /PKGBUILD
parent353a2fe073a899f5b742190f1c6ed60a9436af8d (diff)
downloadaur-66209bb697e7fedaa8998e472ec7dddc60a31d26.tar.gz
follow submodule guidelines
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3b66736424be..5ecb3f05e5bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Paulo Matias <matias@ufscar.br>
pkgname=bluespec-git
-pkgver=r641.e330e11e
+pkgver=r644.91ad4276
pkgrel=1
pkgdesc='Bluespec Compiler (BSC)'
arch=('x86_64')
@@ -14,8 +14,10 @@ optdepends=('tcl: bluesim and bluetcl')
# workaround for pkgrel overwritten on regen (by TkG)
# rebuild whenever some haskell depend is rebuilt
eval pkgrel=$(pacman -Si ${depends[@]} | awk '/Version/{sum+=substr($0,match($0,/[^-]+$/))}END{print sum}')
-source=("git+https://github.com/b-lang-org/bsc.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/b-lang-org/bsc.git"
+ "git+https://github.com/SRI-CSL/yices2.git")
+sha256sums=('SKIP'
+ 'SKIP')
_prefix="/opt/bluespec"
pkgver() {
@@ -25,7 +27,9 @@ pkgver() {
prepare() {
cd "$srcdir/bsc"
- git submodule update --init --recursive
+ git submodule init
+ git config submodule.src/vendor/yices/v2.6/yices2.url "$srcdir/yices2"
+ git submodule update
}
build(){