summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPaulo Matias2020-04-12 11:13:26 -0300
committerPaulo Matias2020-04-12 11:13:26 -0300
commit6fad2972e012afa938ec436161d44c17a5e01831 (patch)
tree3c9ed9621718c0adf23276a20317fab13cef714b /PKGBUILD
parent44c3b338818ed77de0025c734e8ea90ae5f9d7bc (diff)
downloadaur-6fad2972e012afa938ec436161d44c17a5e01831.tar.gz
Make it build!
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 26 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d055a927ce1c..d4f5ce99924c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,20 @@
# Maintainer: Jiuyang Liu <liujiuyang1994@gmail.com>
+# Maintainer: Paulo Matias <matias@ufscar.br>
pkgname=bluespec-git
-pkgver=r3.cc623d8
+pkgver=r285.9dfe8f5
pkgrel=1
pkgdesc='Bluespec Compiler (BSC)'
arch=('x86_64')
url='https://github.com/B-Lang-org/bsc'
-license=('custom')
-depends=()
-makedepends=('git' 'gperf' 'ghc' 'haskell-regex-compat' 'haskell-syb' 'haskell-old-time' 'fontconfig' 'libxft')
-source=("git+https://github.com/B-Lang-org/bsc.git")
-md5sums=('SKIP')
+license=('BSD')
+depends=('tk-itk' 'haskell-old-time' 'haskell-syb' 'haskell-regex-compat' 'haskell-split')
+makedepends=('git' 'gperf' 'ghc' 'xorg-server-xvfb')
+source=("git+https://github.com/b-lang-org/bsc.git"
+ "archlinux.patch")
+sha256sums=('SKIP'
+ '32f1befc93b371c5a744cf01447c8386337641c2efae75090abea0a119e330aa')
+_prefix="/opt/bluespec"
pkgver() {
cd "$srcdir/bsc"
@@ -20,14 +24,29 @@ pkgver() {
prepare() {
cd "$srcdir/bsc"
git submodule update --init --recursive
+ patch -p1 -i "${srcdir}/archlinux.patch"
+ sed -i "s,^BINDIR=.*$,BINDIR=${_prefix}/bin," src/comp/wrapper.sh
}
build(){
cd "$srcdir/bsc"
- make GHC="ghc -dynamic"
+ make GHC="ghc -dynamic" GHCJOBS=2 GHCRTSFLAGS='+RTS -M5G -A128m -RTS'
}
package() {
cd "$srcdir/bsc"
+ install -d "${pkgdir}${_prefix}"
+ cp -dr --preserve=mode,timestamp ./inst/* "${pkgdir}${_prefix}"
+
+ install -d "${pkgdir}/usr/share/vim/vimfiles"
+ cp -dr --preserve=mode,timestamp ./util/vim/{ftdetect,indent,syntax} "${pkgdir}/usr/share/vim/vimfiles"
+
+ install -d "${pkgdir}/usr/bin"
+ local _prog
+ for _prog in bsc bluetcl bluewish; do
+ ln -s "${_prefix}/bin/${_prog}" "${pkgdir}/usr/bin"
+ done
+
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}