summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPaulo Matias2020-05-22 16:44:43 -0300
committerPaulo Matias2020-05-22 16:45:11 -0300
commitd6f3d46a01583db4d59db6d0de20518cd9211b18 (patch)
treebcdc56878ec18cbf94108f39ca1daf3045d980a7 /PKGBUILD
parentb8f2184ebebc2b2552eacd52506358984a269c47 (diff)
downloadaur-d6f3d46a01583db4d59db6d0de20518cd9211b18.tar.gz
patch B-Lang-org/bsc#172
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f1d38cfd506a..a9207e94cfb2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Paulo Matias <matias@ufscar.br>
pkgname=bluespec-git
-pkgver=r297.03e603c
+pkgver=r301.9f4a447
pkgrel=1
pkgdesc='Bluespec Compiler (BSC)'
arch=('x86_64')
@@ -11,8 +11,10 @@ license=('BSD')
depends=('haskell-old-time' 'haskell-syb' 'haskell-regex-compat' 'haskell-split')
makedepends=('git' 'gperf' 'ghc' 'tcl')
optdepends=('tcl: bluesim and bluetcl')
-source=("git+https://github.com/b-lang-org/bsc.git")
-sha256sums=('SKIP')
+source=("git+https://github.com/b-lang-org/bsc.git"
+ "172.patch")
+sha256sums=('SKIP'
+ '6348a39c84eb57920d05e44813bb233ea105e9f7a426255e45286f27ba7c3067')
_prefix="/opt/bluespec"
pkgver() {
@@ -23,6 +25,7 @@ pkgver() {
prepare() {
cd "$srcdir/bsc"
git submodule update --init --recursive
+ patch -Np1 -i ../172.patch
}
build(){