summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJiuyang liu2020-02-05 02:50:55 +0000
committerJiuyang liu2020-02-05 02:50:55 +0000
commitd797bcf3ca1e25bc9a06e49ebe69f27bd00f591b (patch)
tree171ca502529f7db4957c4e95e51e73c79820408b /PKGBUILD
downloadaur-d797bcf3ca1e25bc9a06e49ebe69f27bd00f591b.tar.gz
TODO build failed
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..897c0c43838f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Jiuyang Liu <liujiuyang1994@gmail.com>
+
+pkgname=bluespec-git
+pkgver=r3.cc623d8
+pkgrel=1
+pkgdesc='Bluespec Compiler (BSC)'
+arch=('x86_64')
+url='https://github.com/B-Lang-org/bsc'
+license=('custom')
+depends=()
+makedepends=('ghc' 'haskell-regex-compat' 'haskell-syb' 'haskell-old-time' 'fontconfig' 'libxft')
+source=("git+https://github.com/B-Lang-org/bsc.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/bsc"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/bsc"
+ git submodule update --init --recursive
+}
+
+build(){
+ cd "$srcdir/bsc"
+ make GHC="ghc -dynamic"
+}
+
+package() {
+ cd "$srcdir/bsc"
+}
+