summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStefano Marsili2019-06-15 13:24:44 +0200
committerStefano Marsili2019-06-15 13:24:44 +0200
commitebb3cfec7fbd3ffbc229b51d9ad954f7a6cd405d (patch)
treeb8e2424953aaa2edcbf403a659986c48061294db /PKGBUILD
downloadaur-ebb3cfec7fbd3ffbc229b51d9ad954f7a6cd405d.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..30d6a5e5ab95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Stefano Marsili <efanomars@gmx.ch>
+
+pkgname=bluetoother
+pkgver=0.4
+pkgrel=1
+pkgdesc="Bluetoooth adapter connectivity GUI tool"
+url='https://www.efanomars.com/utilities/bluetoother'
+arch=('x86_64')
+license=('GPL3')
+
+depends=('gtkmm' 'bluez' 'polkit')
+makedepends=('cmake' 'gcc' 'doxygen' 'graphviz' 'python')
+optdepends=()
+
+#provides=("bluetoother")
+#replaces=("bluetoother")
+#conflicts=("bluetoother")
+
+source=('git+https://gitlab.com/efanomars/bluetoother.git#commit=f2ffb7bfd804de01b163e1cf98b89d6160f97ead')
+sha512sums=('SKIP')
+
+build() {
+ cd "${srcdir}/bluetoother"
+
+ ./scripts/install_bluetoother.py -b=Release --installdir="/usr" --no-install --no-sudo
+}
+
+package() {
+ cd "${srcdir}/bluetoother"
+
+ ./scripts/priv/dd_install_bluetoother.py -b=Release --installdir="/usr" --destdir="${pkgdir}" --no-configure --no-make --no-sudo
+}