summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2024-06-10 00:06:03 +0200
committerFabioLolix2024-06-10 00:06:03 +0200
commit42419b3108d0f6794e9a1ac00c7bc2ea63525771 (patch)
treeffcc9f5730641be6ec5d70dab9f6f7c559cfdd53 /PKGBUILD
downloadaur-bluray_info-git.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..165b0f432103
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Fabio 'Lolix' Loli <fabio.loli@disroot.org> -> https://github.com/FabioLolix
+
+pkgname=bluray_info-git
+pkgver=1.14.r0.g0f1a747
+pkgrel=1
+pkgdesc="Blu-ray utilities: bluray_info, bluray_copy, bluray_player"
+arch=(x86_64)
+url="https://github.com/beandog/bluray_info"
+license=(GPL-2.0-only)
+depends=(glibc libaacs libbluray mpv)
+makedepends=(git)
+provides=(bluray_info)
+conflicts=(bluray_info)
+source=("git+https://github.com/beandog/bluray_info.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd bluray_info
+ git describe --long --tags --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd bluray_info
+ autoreconf -f -i
+}
+
+build() {
+ cd bluray_info
+ ./configure --prefix=/usr --with-libmpv
+ make
+}
+
+package() {
+ cd bluray_info
+ make DESTDIR="${pkgdir}" install
+}