summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDerek J. Clark2022-06-06 21:32:31 -0700
committerDerek J. Clark2022-06-06 21:32:31 -0700
commitda4113179d29ab569202ec518439fb0cf421f478 (patch)
tree0cdcfe30622fb6d6e98e57a7f50767ae0a24e1e1 /PKGBUILD
downloadaur-da4113179d29ab569202ec518439fb0cf421f478.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..69a3bd81351c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+_pkgbase=bmi160-aya-neo
+pkgname=${_pkgbase}-dkms-git
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='BMI160 DKMS driver for devices with 10EC5280 ACPI ID'
+arch=(any)
+url=https://github.com/pastaq/bmi160-aya-neo
+license=(GPL3)
+depends=()
+makedepends=(dkms git wget linux-headers)
+source=(git+"${url}".git)
+sha256sums=('SKIP')
+
+package() {
+ cd "${srcdir}"/"${_pkgbase}"
+ local install_dir="${pkgdir}"/usr/src/${_pkgbase}-${pkgver}
+
+ install -Dm644 bmi160_ayaneo.patch "${install_dir}/bmi160_ayaneo.patch"
+ install -Dm644 bmi160_i2c-mods.conf "${install_dir}/bmi160_i2c-mods.conf"
+ install -Dm644 dkms.conf "${install_dir}/dkms.conf"
+ install -Dm755 dkms-patchmodule.sh "${install_dir}/dkms-patchmodule.sh"
+ install -Dm755 dkms.post_install "${install_dir}/dkms.post_install"
+ install -Dm755 dkms.post_remove "${install_dir}/dkms.post_remove"
+ install -Dm644 Makefile "${install_dir}/Makefile"
+
+ # Set name and version
+ sed -e "s/@_PKGBASE@/${_pkgbase}/" \
+ -e "s/@PKGVER@/${pkgver}/" \
+ -i "${install_dir}"/dkms.conf
+}